Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

ps2 and philips 32PF9986 problem

Discussion in 'Philips TVs Forum' started by dave04, Aug 16, 2005.

Tags:
  1. dave04

    dave04
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Ive had my 32PF9986 a few months firmware 2.3, have tried connecting PS2 to side connections.

    When ps2 loads a sound and audio comes for a few seconds, but then picture doesnt load only the sound.

    Tried different phono connection leads and these same leads on a normal tv and the cables where all fine.

    Xbox worked fine on 32PF9986 using side connection.

    Is there anything I could try? Or ask for a repair
     
  2. jimsan

    jimsan
    Active Member

    Joined:
    Oct 8, 2004
    Messages:
    1,610
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    Dumfries, SW Scotland.
    Ratings:
    +9
    My PS2 is connected this way too and it works fine. It's not the best way to do it, but it's adequate for my purposes.

    It sounds to me like you have a faulty connection on your yellow lead, either at the PS2 end or the TV end. Do some wiggling!

    Jimmy
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice