Proliant MicroServer + FreeNAS + WOL?

showl

Standard Member
I'm interested in whether anyone has managed to get Wake On LAN working using a HP Proliant MicroServer running FreeNAS 7.2?

I've seen a few people refer to WOL on a variety of threads, both here and elsewhere, but not yet found a definitive answer as to whether this is possible. Hoping someone here can say for sure.

There seems to be some suggestion that it is only possible by adding a second (and almost redundant) NIC which fully supports WOL as the FreeNAS/NIC combo appears not to.

Any thoughts?
 

poiuytre111

Standard Member
I am also trying to get WoL working on a HP microserver using Freenas 0.7.2
Appears from googling that 7.2 drivers are the issure rather than the nic itself. If we fit a second nic supported by suitable freenas drivers this would fix it, as would finding a way to get freenas to use a better driver for the microserver.

Anyone got this to work yet ?
Steve
 

showl

Standard Member
Agreed it does look like an issue with the drivers that FreeNAS 7.2 supports.

Spent the last week trying to get around the problem by adding a second NIC card (Dynamode PCIe NIC) that uses a VIA VT6130 chip-set that is listed in the FreeBSD hardware list. However still no luck.

I don't think the fact it's a cheap card is to blame as it states it supports WOL and yet it resists any attempt to configure it. ifconfig clearly shows that WOL isn't a capability.

Admittedly this is very much "trial and error" cause this isn't really my area of expertise. So if anyone has any suggestions I'd be interested to hear them!
 
Last edited:

jerrymac

Novice Member
Have you enabled WOL in the BIOS of the Microserver?
Also need to enable it on the onboard NIC ....
 

showl

Standard Member
Yes, definitely enabled in the BIOS.

Is there some other way to go about enabling the on the onboard NIC?

Cause so far I've tried...

ifconfig msk0 wol
ifconfig msk0 wol_magic
ifconfig msk0 wakeon magic

(all dervived from various forums, etc)

Have just noticed something interesting. According to the ifconfig the interface driver that FreeNAS has selected is "msk", yet from the FreeBSD hardware list the "vge" should be the correct driver. Whether this is part of the problem or a red-herring I have no idea!
 
Last edited:

showl

Standard Member
Perhaps you could clarify. What exactly worked under fedora and ubuntu?

That specific NIC? the msk driver? or simply those ifconfig commands?


Thanks in advance
 

stiscooby

Novice Member
Might not really help here as I haven't used FreeNAS but I have WOL working on mine running WHS 2011.

I can power mine on when it's powered off (i.e. not gone to sleep etc). I have turned on the options on the NIC from within WHS but surely this must just write something back to the card and save it as once the server is powered off it shouldn't matter what software your actually run on it.

Might be a bit of messing about but what about installing windows onto a disk so you can then set the settings on the NIC then power off and test. Once that works just put a disk back in with FreeNAS on it/re-install FreeNAS?
 

The latest video from AVForums

Podcast: Marantz SR7015 & NAD T 778 AVR + Mission LX2 MKII Speaker Reviews, AV & Film News and More
Top Bottom