Projector showing hundreds of dots on screen

trivialsid

Active Member
Would anyone have any idea as to the problem I have in that the HD67n is showing hundreds of tiny white dots on screen, its not the obvious of dust on lens as have cleaned that, thancks in advance of any help.
 

kbfern

Distinguished Member

trivialsid

Active Member
Thancks for information, the HD67n is over a year old so expect out of warranty, I was already contemplating upgrade to HD300 or HD33 but was hanging back as my thincking was that it could be due for new models to replace them due to the time they have been out, this will probaly now make my mind up to go ahead anyway.
 

Peter Parker

Distinguished Member
Would you say the dots were flickering on/off a lot and were more noticeable in dark areas (sometimes called mosquito noise)? If so, it could be that your brightness is set too high.

You can set it correctly using either a test disk with test patterns that allow you to set the levels correctly, or you can play a 2.35 movie so you have the black bars top and bottom, and then slowly reduce the brightness control until the flickering dots in the black bars disappear. To get it spot on you may have to raise then lower the brightness in small increments so the dots are just extinguished, because lowering it too much will mean you will be losing shadow detail.

There is some info with avforums videos in a link in my sig (basic projector calibration) which should help.

Gary
 

Tight Git

Distinguished Member
Just to be clear, is it ONLY dots that you're seeing on the screen, or are they on top of an otherwise normal picture?
 

trivialsid

Active Member
Thanck you all for your help, the white dots are on the screen with or without the picture , which shows over them, there must be over a thousand of them taking about half of screen, they are static and it would be like looking at stars in sky on clear night, as I may have nothing to lose Im pondering on giving projector good shake on possibility of stuck mirrors.
 

toddy28

Well-known Member
trivialsid said:
Thancks for information, the HD67n is over a year old so expect out of warranty, I was already contemplating upgrade to HD300 or HD33 but was hanging back as my thincking was that it could be due for new models to replace them due to the time they have been out, this will probaly now make my mind up to go ahead anyway.

You get a 3 year warranty on the hd67 (might be 2 now but your still in ) so your in luck my friend , get it fixed then sell it on ready for upgrade time I went from a hd67 to a hd33 and it's a huge leap in quality
 
Last edited:

trivialsid

Active Member
Have tried plugging and unplugging and new leads, emailed optoma who emailed back REM form which Ive copied and posted today, it may be dependant on optoma goodwill as they wanted proof of purchase which I can not find but they will try and find if they have it on file, ( Ive always assumed in this computer age that purchases are on file). I will update this thread with any news on what has happened in this case, it adds to the knowledge of us all when problems are solved, thancks again for everyones help.
 

The latest video from AVForums

Are the TCL MiniLED TVs better than OLED? TCL Interview with Marek Maciejewski | AVForums Podcast
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom