Problems with the Epson SX515W


Active Member
ok, am about to tear my hair out with this god forsaken printer!!!:mad:

This is a replacement that was delivered this morning to me as the 9month old one decided to start printing oddly with just one colour, and then not at all. And despite whatever i did it wouldnt change, so Epson arranged a replacement.

Im about to throw it across the room!!! I did the set up, with the USB and the Wi-Fi. Still not working. Did the Windows fix. Still not working. did a ping check between my laptop and the printer and there was an open link. Changed the port (this was all done on advise from this page that they directed me to (Session Timeout)
ive done it to the best i can, ive been messing with it since 12pm and im losing total hope in getting it working.
The ink is full in the printer, but shows as empty on the computer.
The WiFi Status Sheet says its fine.
I tried twice to do an online chat with Epson, and theyre like robots, i swear, theyre replies was the same to the letter.

is there any advice on this, before i give up hope and just buy another!!!??
Bear in mind, it would have come to me as a new one this morning, but i dont know what to do!!

Can anyone please help!!!!:lease::lease:

The latest video from AVForums

Paramount + UK launch: Halo, Star Trek and Beavis, and all the latest 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom