Problems with Sony W5500

Becco

Active Member
Hi wondering if you could help, I've just bought the Sony W5500U, disconnected my old Toshiba LCD (which had the ps3 and Sky running through HDMI), and reconnected it to my new tv. The sky HD is working perfectly, but the ps3 is just a blank screen through hdmi (but works through composite/component), any ideas???? Its driving me mad!! :(

Thanks
 

MichaelGL

Novice Member
Turn the PS3 off. Then turn it on but hold the power button until the second beep.

This may sort it although I'm fairly sure if you connect a HDMI cable then the PS3 auto detects it and switches to it.
 

Becco

Active Member
Thanks for the reply, but I tried that one :thumbsdow

Will maybe give it another go though! Can't understand why it works through hdmi on one tv, but not another :confused:
 

Foghornleghorn

Novice Member
Thanks for the reply, but I tried that one :thumbsdow

Will maybe give it another go though! Can't understand why it works through hdmi on one tv, but not another :confused:
You have to select the HDMI # where you have your PS3 connected. I.e...If you connected the PS3 using HDMI 1, then by using your remote press the top left hand button and select that HDMI number.
 

Foghornleghorn

Novice Member
Yep definately have the right hdmi channel selected...
Have you tried the PS3 in another Hdmi slot? This may sound silly... but have you checked that both connections (ps3 and tv) are seated properly.

P.s... You've established that your Sky Hd is working correctly.Why not remove the Hdmi from the Sky box and plug it into the PS3, this will give you an idea as to any problems with the PS3 or Hdmi cable.
 
Last edited:

The latest video from AVForums

Podcast: Philips OLED+935 impressions, Denon AVC110 Review, Film Reviews, News and More...
Top Bottom