Problems with Panasonic E50 DVDR

Discussion in 'Blu-ray & DVD Players & Recorders' started by PLASMABABBY, Nov 1, 2004.

  1. PLASMABABBY

    PLASMABABBY
    Active Member

    Joined:
    Jul 2, 2004
    Messages:
    397
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Walsall
    Ratings:
    +15
    Hi everyone,
    I have a multiregion Panasonic E50 DVD recorder which is about 18 months old.
    It has always performed faultlessly but last night, I tried to play several Region 1 discs and the picture was so jittery and slipping up and down that they were unwatchable. I've checked all connections (Use Thor Scarts for connections).
    It still plays Region 2 discs OK and also RAM discs are no problem.
    Has anyone any idea why the machine would suddenly start playing up like this. Nothing has been changed in the set up.
    Any help would be much appreciated.
     
  2. OARDVD

    OARDVD
    Standard Member

    Joined:
    Jul 6, 2003
    Messages:
    241
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    Deepest Hertfordshire
    Ratings:
    +0
    Are you sure it’s not your TV / display device failing to display an NTSC signal properly? R1 discs are NTSC (60Hz) whereas your R2 discs will be PAL (50Hz). So does it have this problem with more than one TV? If it occurs on more than one then it’s likely that the E50 is faulty. If it plays R2 discs ok then it sounds like possibly the NTSC circuitry.
     
  3. PLASMABABBY

    PLASMABABBY
    Active Member

    Joined:
    Jul 2, 2004
    Messages:
    397
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Walsall
    Ratings:
    +15
    Hi OARDVD,
    Thanks for that advice.
    The display device is a 42"Panasonic PWD6 so
    I've tried playing the Region 1 discs with a multiregion DVD player connected to the Plasma instead of the E50 and the discs play with no problem.
    So it looks as though you may be right in saying that the NTSC circuitry in the E50 could be faulty.
    I'll try the E50 on another TV and that should confirm whether it's faulty or not. Hope it's not - can do without the expense of a new DVDR at the moment.
     
  4. PLASMABABBY

    PLASMABABBY
    Active Member

    Joined:
    Jul 2, 2004
    Messages:
    397
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Walsall
    Ratings:
    +15
    Hi OARDVD,
    Because of your suggestions, I went into the setup menu of the Plasma and found that the signal selection had been changed from 'Auto' to 'PAL' but don't know by whom - no one will own up.
    Changed it back to 'Auto' and Hey Presto - all is fine again.
    Many, many thanks. Without your advice I would never have thought to check that menu.
     

Share This Page

Loading...