Quantcast

problems with Monitor Audio radius 360

happychappy

Active Member
Has anyone suffered any problems with the Monitor Audio Radius 360 sub? although it still works o.k. the blue power on L.E.D. on the front panel which lights up when a signal is sensed has gone kaput! obviously its still under warranty but at this point I shall wait till my hols for a repair (as I have been quoted a couple of weeks and am at the moment only running this system as my new "mini Cini" room nears its final completion)
Thanks in advance for your replys :confused:
 

p0kerm0n2004

Novice Member
I have this problem too - never bothered to get it fixed, but it is annoying. Would be interested to hear how you got on.
 

happychappy

Active Member
Hi all

Shortly after the "blue light" incident I managed to de-laminate a speaker cone (it simply came unstuck from the unit) leaving me no option but to seek a repair, I took both the speaker and sub back to "sevenoakes" where a repair was undertaken, both within 1 week and to date have had no further problems (touch wood!)

:thumbsup:
 

Neil Davidson

Well-known Member
AVForums Sponsor
I have had two units where the LED has gone. It didn't bother me much as the damn thing burns your eyes out in a dark room but it was useful to indicate when the sub was alive and when it wasn't.

I accepted an extra year of warrenty in return for keeping the second unit as I was told that they had only had it happen three times world wide. There's nothing worse than getting lied to by a supplier as it would clearly seem the problem is more widespread than they have let on.

On both of my subs the LED went within a few days. On the first one it started working again for a couple of days after I moved it but it then went completely.

Does my experience match anyone elses?
 

engaged

Member
Sorry to hear about your probems with the MA sub - just makes all the more glad to have bought an M J Acoustics Reference 100 instead of one... :cool:
 

happychappy

Active Member
ceenhad said:
"There's nothing worse than getting lied to by a supplier as it would clearly seem the problem is more widespread than they have let on."
Exactly how I feel I was also told that I was the first!..(how many times have you heard that from a lady!) I bought the units with honest hard earned money and expect the same from the re-sellers and manufacturers.
Maybe I will have second thoughts on the dem of the MA GR 10 speakers that I had included in my shortlist for future audio upgrades? :mad:
 

p0kerm0n2004

Novice Member
ceenhad - my experience has been identical to yours right down to it working again for a few days when moved a couple of feet!

happychappy - which branch of Sevenoaks did you buy from as I also bought from them (in Weybridge) and it may be helpful if I can refer to your problem and branch when taking in for repair - thanks.
 

happychappy

Active Member
p0kerm0n2004 said:
"happychappy - which branch of Sevenoaks did you buy from as I also bought from them (in Weybridge) and it may be helpful if I can refer to your problem and branch when taking in for repair - thanks."
The package was bought from their Southgate branch North London
pleased to be of service
:)
 

Similar threads

Top Bottom