Quantcast

Question Problems with a new 75" TV

crelu

Novice Member
Hi.
I have recently bought a new UE75RU7105, I was half expecting it to be bad or worse than my old plasma tv, thinking I was just paying for the size and it would be lacking in everything else.
Sure It's not an oled but I was very pleasantly surprised and I think It's great!

Though I have encountered a couple of problems and I still have the possibility to return it and not have to go through an rma which takes weeks. I just hate that and want to avoid it like the plague.
If I notice anything early on I just want to return the damn thing within the 14 day return period.

So I just wanted to ask you what you think about these problems, if it's normal and so on.

First of all, during the initial setup It wouldn't connect to my wifi, It would load for half a minute and then just go back to the previous screen and not find any networks.
I then had to skip that step to be able to proceed as it wouldn't work. Later in the settings I did a "network reset" as well as turning the tv off, removing the power cable and then back in and started it, after that it did work fine.
Today It just stopped working again as I turned my TV on. What do you think the problem is?

Another thing I'm noticing is the plastic cracking/popping, I've had TV's do that before when you turn them off the plastic would do this as it's cooling down.
This TV does it all the time though, while on and going from a dark image to a very bright one there seems to be a lot of popping sounds for a second.
It's just doing it a little here and there even if it's been on for a few hours. The TV is hanging on a wall mount.

So what would you say about this? What could be causing the wifi problem? Is the popping/cracking noises normal?

Thank you in advance!
 
Top Bottom