problems connecting streamers to some network shares

unique

Moderator
i have two streamers, an ac ryan mini and an asus one. both use the same or similar chipsets i think (realtek?)

i recently upgraded pcs and went from xp to win7 and whilst both streamers could access all files/folders/drives on both pcs previously without needing any passwords or usernames, i'm having a problem where roughly half the drives on one of the pcs can be accessed from the ac ryan without a password, but to access the other drives on the same pc i have to enter a username and password on the ac ryan, which is a PITA. it would also mean that if i had friends over and i wanted to play something on that drive they could see my typing in my password

on the asus, it used to see and access all drives on both machines, but can't because of the password issue, although typically i access files from the streamer in each room to the pc in the same room, so it might just be the settings on the other pc, although on the ac ryan it can browse the other pc fine

looking at the network share settings all drives and pcs appear to have the same settings, but maybe there are other settings that are more hidden that i've not noticed

i basically want to share all files and folders on both machines to be accessed by any network device on my home local network without a password etc. i've tried looking at settings via googling up, but can't figure it out

i thought as it's mainly the streamers that are affected that i'd perhaps get the best advice from the streamer forum as presumably someone has encountered the same problems whilst setting up their own streaming
 

MarkE19

Moderator
Windows 7 has a mind of its own when it comes to shares to non Win7 devices :rolleyes:

This has been a big issue for many users of streamers so have a look at the following thread which has a lot of info on the setting up of shares. Yours is a different streamer to the one mainly mentioned, but I would guess most of the issue relate to Win7 so should still be valid for you - http://www.avforums.com/forums/stre...-seriously-popcorn-200-struggling-set-up.html

Mark.
 

next010

Distinguished Member
You might want to also take a look at this guide for sharing through SMB & failing that this.

The problem is MS uses Homegroups [with SMB the underlying protocol] to share media in Win7 but nothing else has adopted Homegroups, not sure even if they can and the UI for sharing out folders the old way over SMB is buried away within the GUI.

Also watch out if you have anything from Windows Live installed like sign in assistant or games for windows live, there is a bug in samba the open source version of SMB that prevents them from connecting to SMB shares on PC's with Live apps present, the issue has been fixed in samba but not all media players have updated their firmware with the newer builds of samba.
 

unique

Moderator
thanks guys, i finally got it working!

in a nutshell i read all the links and changed my options following this guide, but that still didn't fix it... (but it might have helped)

https://lh5.googleusercontent.com/_...EVQ4FDvxQ/Local Security Policy (Sharing).png

then i read about the security tab and noticed that the drives that were working had permissions setup for "everyone" whilst the drives that weren't working didn't have "everyone" listed as an option. thus i edited and added "everyone" to the other drives and it now lets me access any drive without the password prompt. i've just tried it on my my streamer and pc, but i've set the permissions on the other pc and will try that later

the security bit is as follows...


My problem was I was trying to share the root directory for two of my hard drives on Windows 7 x64. I had installed two new hard drives and assigned one of them as E:\ with the label Movies and the other as F:\ with the label TV Shows and then proceeded to place the files directly in the root directory. When I went to my Revo to add the shares in XBMC, it could see them, but it would ask me for the password even though there were none set up. The weirdest thing was I had other folders on my D:\ drive that XBMC had no problem accessing without a password, but for some reason it didn't like my root directory shares. I had set up all of the permissions and user groups the exact same as those folders for my root directories so I couldn't for the life of me figure out why XBMC couldn't add them because they were no different than the folders I was already sharing.

After doing some internet scouring I finally found the solution. You do everything that was described in the first post and treat the drive just like a folder, but you have to do one more step after setting up permissions. What you have to do is add the user group Everyone in the Security tab for the hard drive. You do this by going to Windows Explorer and Right clicking on the hard drive you want to share (D:\, E:\, etc.) -> Properties -> Security tab -> Edit -> Add -> Type in "Everyone" -> Hit Enter -> Apply -> OK -> OK

After that, XBMC shouldn't ask you for a password when you try to add that root directory as a share. Enjoy!

the quote is post 37 from the following link

[WINDOWS] HOW-TO share folders over SMB using Windows 7 - Page 4 - XBMC Community Forum

so hopefully this might help other people with similar problems

i think part of the issue is that the drives that work were setup on my old pc under xp, but the drives that didn't work were formatted under win7 before use, thus the working permissions must have been carried over from the old system
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom