Problems charging Harmony 895

ellchester

Active Member
I've only had my 895 a couple of weeks but it has stopped charging properly. It doesn't seem to sit properly in the cardle anymore and the contacts don't appear to be meeting. I've read of a similar problem with the 885 but I thought it was fixed. Anyone had similar with the 895?
 

ralphmalph

Novice Member
I had this problem and I have an 885. My solution was to put a bit of card at the bottom of the battery to wedge it in. Now that the battery is making firm contact with its connectors I have no problem with charging in the cradle.

Try it. But it is still a pixxer that a premium product can not even charge properly.
 

ellchester

Active Member
Tried that but no luck - not very impressed with the 895 so far.
 

ellchester

Active Member
Just spoke with Logitech Harmony helpline. They said some cradles shipped with "a problem" and they're going to get a different dept to get back to me.
 

Dunwa

Active Member
If you don't mind me asking where did you buy it from ?
 

ellchester

Active Member
Komplett
 

Dunwa

Active Member
Well mine should arrive from Komplett in a few days, i'll post if I have any problems
 

ellchester

Active Member
Still having problems and Logitech's helpline has been terrible. Promised emails and calls but still waiting - going to return it to Komplett. Very disappointed in it for £200.
 

John P.

Novice Member
I had the same problem from day 1 with my 895 (brand new this last Thursday).

I almost ruined both my battery and the remote because of this - I still don't know what minor faults it might have caused...

Anyway - when I figured out the charger wasn't working correctly, and that I had to press the remote down on the cradle to make it charge, I ended up putting something slightly heavy (a 25 DVD spindle) resting on the front of the remote (the edge of the spindle resting just in front of the Off button without of course it touching any buttons).

That way the remote was pressed down in front, and charged properly.

Shouldn't have to do that, and what will it do to the second hand value?, but you gotta do what you gotta do. ;)
 

ellchester

Active Member
John P. said:
I had the same problem from day 1 with my 895 (brand new this last Thursday).


Shouldn't have to do that, and what will it do to the second hand value?, but you gotta do what you gotta do. ;)
It's simply not good enough and I'm trying to get Logitech/Komplett to send a replacement cradle. However, Logitech's customer service has been AWFUL so far. Will let you know if I get a resolution.
 

John P.

Novice Member
I think actually it could be potentially dangerous, so Logitech should really re-design the whole thing.

-When I first got my remote, I put it in the charger so I would get full functionality (as it also states in the leaflet that comes with the remote).

What happened when I put it in the cradle was that the Logitech logo was shown on the LCD, and the upper part of the display was pulsing. I took this as a sign that it was indeed charging. But the battery indicator did not fill up then empty rapidly and steadily as it's supposed to during charging. It was stuck at one mark on the indicator. Still - since the remote was seated on the charger, and since the LCD's upper part was pulsing, I thought it was charging anyway.

Now here comes the potentially dangerous part:

I had the charger close by my computer at the time. And after a while, I could hear fizzling and "scratching" noises coming from the battery, and the remote got quite hot in the back. All the while the remote exhibited weird behaviour, like suddenly showing a menu screen, beeping etc, and claiming "USB CONNECTED" when it was not the case...

I left the remote over night like this, thinking it would still be OK in the morning, and the morning after the remote was completely dead - no button pushing would wake it up. I only got life back into it when I hooked it up to USB.

When I then realised the charger was faulty, and I let it charge with the DVD spindle pressing it down on the cradle for the next night, it was all OK thankfully the next day.

But thinking back, those noises coming from the remote as it was "charging" were a little unnerving.
 

ellchester

Active Member
Just had an email from Harmony (eventually) saying i need to post the battery and ac adaptor back to Switzerland! They clearly are not listening to the problem as it seems to be the cradle or cradle design as if you push really really hard contact is made and it charges, otherwise it doesn't. I'm not sending it back and have spoken toa girl called Nikki at Logitech Head Office who said she is going to look into it and get back to me. She said it's not something they know about which isn't supported by the Harmony helpline who said some cradles had been shipped with a problem, the problem mentioned on this site with the 885 charging, and the other problem mentioned on here....
 

DARKFiB3R

Standard Member
I just got my Harmony 985 this morning and it wouldn't charge properly at all.

Well I wasn't having any of that nonsense, was I? So I opened up the charging cradle and bent the prongs upward. No joy, so I opened it up again, just to have a look, and noticed that the negative wire from the battery had been crushed by part of the casing. I don't know if I did that when I put it back together the first time or if it came like that! Anyway it still wasn't working so next I tried updating the firmware on both the remote and the RF Receiver. Hay Presto!!! It now works perfect every time now. Phew!

Not sure if it was just the firmware update, or if it was the combination of that, and bending the prongs up that sorted it, but hay, it works! :smashin:

Hope this might help a few people :)
 
Top Bottom