Problem with Zidoo Z10 PRO

Magoyle

Novice Member
Hi, I am an italian customer and this is my first post, so, sorry for my sure mistakes.
I bought a few days ago Zidoo Z10 Pro.
1- Immediately I see that the front display doesn't work. Do i have to insert a battery inside? Is it a CR 1220 model?
2- Unfortunately I noticed that it does not read all video formats and this is a problem for me because I have many. How can this be solved?
3- Using "home theater 4.0" with the Italian language set, I can't get information about the films in Italian, he always gives them to me in English. How can I do?
4- I initially had an A410 popcornhour where each movie had cover art, fanart and info. Now browsing in the "media folder" I can't see the previews in the file list as with the previous player, is it possible to see the previews? Now I see the list with:
ES "ABC" film title:
ABC.avi
ABC.jpg
ABC.fanart.jpg
ABC.info

Thanks in advance to everyone who can help me and sorry for any mistakes.
Guido
 

DELUCAS

Distinguished Member
If your front Display does not work you have a fault return unit back to seller !
replacing the battery will not fix it !
 

Magoyle

Novice Member
I wrote "Do i have to insert a battery inside?" not to replace it...
I have seen and read in various tutorials that sometimes the battery is missing in the motherboard for import reasons. I have not opened the z10 to see why it is still under warranty, so I don't know if there is a battery or not.
 

DELUCAS

Distinguished Member
I wrote "Do i have to insert a battery inside?" not to replace it...
I have seen and read in various tutorials that sometimes the battery is missing in the motherboard for import reasons. I have not opened the z10 to see why it is still under warranty, so I don't know if there is a battery or not.

With or without battery will not fix your front Display !
Either poss a connection problem to Display window of unit or faulty Display .
Either way it be under warranty so return unit for replacement etc .
 
Last edited:

Magoyle

Novice Member
With or without battery will not fix your front Display !
Either poss a connection problem to Display window of unit or faulty Display .
Either way it be under warranty so return unit for replacement etc .
Ok. Thank you. But the battery then what is it for?
 

Magoyle

Novice Member
Dear DELUCAS, can you answer my other questions?
With regard to question n.3: I see that the info is in italian only setting the english language in HT e the italian language in the general setting...
 

DELUCAS

Distinguished Member
Ok. Thank you. But the battery then what is it for?
Keep the time for when unit is Powered off so dont rely on the internet connection etc .
So dont really req it as such as soon as unit is powered up it connects to the internet as adjusts / updates time .
 

Magoyle

Novice Member
Thanks DELUCAS

1- I think I will be replaced under warranty for the display issue.

3- For the language of HT I have already done the update, but I have not solved it, I see the plots in Italian only for some films and only by setting Italian in the "general" and English in HT.
 

The latest video from AVForums

Panasonic LZ2000, LZ1500 & LZ980 Hands-on Launch Event | No QD-OLED for 2022, new 77-inch for LZ2000
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom