Problem with PowerShot A520

Discussion in 'Photography Forums' started by FunkyMunkey, Apr 30, 2007.

  1. FunkyMunkey

    FunkyMunkey
    Active Member

    Joined:
    Aug 25, 2006
    Messages:
    1,591
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Leeds
    Ratings:
    +154
    Hi,

    I'm having a bit of a problem with my Canon camera.

    It seems to think that the batteries are dead after just 5 photos. I originally thought that my charger wasn't charging the batteries properly, but I tried a brand new set of regular batteries and I had the same problem. :confused: :confused: The camera is about 20 months old.

    Does anyone have any suggestions? Is there anything I can do myself? Should I take it in to be repaired, or should I just sell it as faulty on fleaBay?

    Any help would be much appreciated

    Edit: sorry, it's a Powershot A520!
     
  2. FunkyMunkey

    FunkyMunkey
    Active Member

    Joined:
    Aug 25, 2006
    Messages:
    1,591
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Leeds
    Ratings:
    +154
  3. denno75uk

    denno75uk
    Well-known Member

    Joined:
    Oct 17, 2006
    Messages:
    1,980
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    116
    Location:
    Leeds..out of Prescot
    Ratings:
    +574
    I posted a thread asking the same question.

    See here.
     
  4. FunkyMunkey

    FunkyMunkey
    Active Member

    Joined:
    Aug 25, 2006
    Messages:
    1,591
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Leeds
    Ratings:
    +154
    Thanks, but that's definitely not the problem.

    I've had the camera for 20 months and took thousands of pictures with it on a round-the-world trip without this problem occuring. I'm also using 2500mAh batteries and, as I said, had the same problem with brand new batteries straight out of the box.

    Any other ideas?
     
  5. senu

    senu
    Distinguished Member

    Joined:
    Aug 26, 2005
    Messages:
    19,349
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Denham, South Bucks
    Ratings:
    +2,811
    It sounds faulty.. before you "sell it off" contact Sony as it might be a known problem with a few of them and be fixed for free.. you have nothing to lose. really

    PS: The thread title has been renamed appropriately
     

Share This Page

Loading...