Problem With Network Settings (DNS)

echoUK

Well-known Member
Hi guys,

I'm having a few problems trying to set my 360 up so that I can connect to LIVE! and play online. Basically, I upgraded to a wireless router about a month ago and I mainly use my PS3 for gaming, but every now and then I fancy a bash online with the 360. Before I got my wireless I could connect ok (although I had similar problems at first), but after a little fiddle about with a few settings I managed to get connected.

When I first got my wireless router it was in my bedroom and I had actually been able to connect my 360 to it fine by connecting the ethernet into the back of the wireless router itself and setting all the settings to automatic and it connected straight away. Since then though I have moved my wireless connection downstairs because when it was in my room it was actually quite far away from the actual telephone terminal and my Internet speed wasn't as fast as it could be (I was using a really long phone line). Since I've moved it downstairs though my Internet speed has more than doubled, so I don't really want to move it back into my room and slow it down again just for the sake of being able to use the 360 once in a while.

Basically, I'm trying to connect my Xbox using Internet Connection Sharing, which I was doing before I got my wireless connection. I've just spend the last hour or so trying to get my 360 online and it's not having any of it. When I go to 'Test Network' it's passing the first stage fine (actually finding a connection to the computer it's plugged into via ethernet). It's just the next part where it keeps coming up as failed (I think it's the Internet stage where it tries to connect to the internet). When I go onto 'More Info' it says something about not being able to pick up the DNS settings or something and tells me to have a look on the Xbox website. Which I have done and I've tried what it says on there and I still get the same problem.

I've tried everything as automatic and it doesn't work and I've also found out my DNS settings through typing ipconfig/all in the command promp (as what I was told to do on the 360 site). I've then entered the DNS settings manually into my 360 and it's still coming up with the error with the DNS.

Does anybody have any clues as to what I'm doing wrong, as the 360 is connecting to my computer fine, it's just when it tries to make a connection to the net where it keeps coming up as failed and I've tried entering my DNS address but still getting the same.

I'm not really clued up when it comes to IP addresses and network things like that so any help/guidance would be very much appreciated.

Thanks to anybody that can help.
 

Big_Dan_C

Active Member
hi echo,

so you're pinching your broadband from another computer which is conected wirelessly to the router - is this right?

when you did the ipconfig did you get a DNS number? are you runing vista or xp on the computer?
 

echoUK

Well-known Member
That's right mate yeah. I have my wireless downstairs and I'm using my laptop in my room, which I'm trying to connect my 360 to via ethernet and Internet Connection Sharing.

I did get my DNS number from the ipconfig. I've noticed something else though - I have a Thompson router and when I go into the settings for it from Firefox, it gives me details of how long I've been connected, how much I've downloaded, etc. Along with my IP address and DNS settings. However, the DNS settings on this settings/administrator panel I load up in Firefox is different to the DNS setting that is listed when I type in ipconfig in command prompt. There's two DNS settings on the Thompson page, a primary one and secondary one and both are different to the DNS setting number I have listed when I type in ipconfig.

I've tried putting all three DNS numbers in on my 360 and LAN connection properties thing but I'm still having no luck.

Edit: I'm also using Windows XP.
 
Last edited:

Big_Dan_C

Active Member
sorry its taken me a while to get back to you - sounds like it might be your firewall, each time you change a setting in the network ip address you might need to power off and on the router and PC (and probably the xbox as well).

try the following: (which I've pinched of microsoft website)


  1. On the computer, click Start, click Run, type ncpa.cpl, and then click OK.
  2. On the View menu, click Tiles.
  3. If the connection is listed as Firewalled, the firewall may have to be configured. See your firewall documentation.
  4. Enter manual settings in the Xbox 360 Dashboard for IP address, subnet mask, DNS address and gateway and test the connection: To edit the settings:
    1. In the Xbox 360 dashboard, move to the System section.
    2. Select Network Settings.
    3. Select Edit Settings.
    4. Enter the following:
      • IP Address : 192.168.0.2
      • Subnet mask : 255.255.255.0
      • Default Gateway : 192.168.0.1
      • DNS server (Primary): 192.168.0.1
      • DNS server (Secondary): 192.168.0.1
if the DNS address' don't match your router try changing them - if that fails it still could be your firewall - even the windows firewall. try turning it off and setting the network security to low - just to try it, you can restore them after the test and at least we'll know if its that.
 

The latest video from AVForums

65-inch LG C1 Review coming soon to AVForums
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom