Problem with MS Film&TV app, picture too dark

timoat

Active Member
Ok, so trying to play a movie (Blade Runner 2049, dl with Atmos track)) from my Laptop, on to my samsung screen. Ive just bought an JBL 9.1 Soundbar, bc I wanted Atmos. I bought the Dolby Access app, and can get Dolby Atmos to work if i play the movie with Microsoft Film&TV. I cannot get Atmos with VLC or Potplayer, its goes . However, the picture is very dark in MS Film&TV, compared to VLC and Potplayer, which are both a shade lighter, and more saturated. There seem to be no way of adjusting these settings in MS Film&TV.

Can anyone help, or recommend a better player for Atmos films?
 

next010

Distinguished Member
Ok, so trying to play a movie (Blade Runner 2049, dl with Atmos track)) from my Laptop, on to my samsung screen. Ive just bought an JBL 9.1 Soundbar, bc I wanted Atmos. I bought the Dolby Access app, and can get Dolby Atmos to work if i play the movie with Microsoft Film&TV. I cannot get Atmos with VLC or Potplayer, its goes . However, the picture is very dark in MS Film&TV, compared to VLC and Potplayer, which are both a shade lighter, and more saturated. There seem to be no way of adjusting these settings in MS Film&TV.

Can anyone help, or recommend a better player for Atmos films?

Dolby TrueHD Atmos can be passed as TrueHD audio via media player, you don't actually need the dolby access app.

Also your laptop must be plugged into the soundbars HDMI input of course.

Within VLC go to tools->preferences->audio->HDMI/SPDIF audio passthrough = enabled
Device = HDMI output.

Your TV's picture settings should be on black level High to match PC output as well if your only using SDR output.

If using HDR video thats another can of worms.
 

timoat

Active Member
Dolby TrueHD Atmos can be passed as TrueHD audio via media player, you don't actually need the dolby access app.

Also your laptop must be plugged into the soundbars HDMI input of course.

Within VLC go to tools->preferences->audio->HDMI/SPDIF audio passthrough = enabled
Device = HDMI output.

Your TV's picture settings should be on black level High to match PC output as well if your only using SDR output.

If using HDR video thats another can of worms.
hello, thank you for a thorough reply!

I followed your instructions to the letter, but unfortunately the soundbar still displays Dolby Surround when using VLC, instead of Dolby Atmos DD+ that i get when playing the exact same file though Microsoft Film&TV app. (but then i get the darker picture. In vlc the picture is fine)
 

next010

Distinguished Member
hello, thank you for a thorough reply!

I followed your instructions to the letter, but unfortunately the soundbar still displays Dolby Surround when using VLC, instead of Dolby Atmos DD+ that i get when playing the exact same file though Microsoft Film&TV app. (but then i get the darker picture. In vlc the picture is fine)

DD+ Atmos is not the same as TrueHD Atmos.

You need a media player which can pass EAC3 try MPC-BE.

Click on view->options->internal filters->audio decoders->audio decoder configuration.

Under pass through select AC3, EAC3 and TrueHD (if using ARC deselect TrueHD).

Now back on options menu select audio->audio renderer and select the HDMI output.

See if that works, you may also have to manually select the DD+ track in the video if there is more than one just right click on the video while playing and select the correct audio track.
 

timoat

Active Member
DD+ Atmos is not the same as TrueHD Atmos.

You need a media player which can pass EAC3 try MPC-BE.

Click on view->options->internal filters->audio decoders->audio decoder configuration.

Under pass through select AC3, EAC3 and TrueHD (if using ARC deselect TrueHD).

Now back on options menu select audio->audio renderer and select the HDMI output.

See if that works, you may also have to manually select the DD+ track in the video if there is more than one just right click on the video while playing and select the correct audio track.
ok, thank you, i will try it! so what is the better one, dd+ or True HD?
 

timoat

Active Member
DD+ Atmos is not the same as TrueHD Atmos.

You need a media player which can pass EAC3 try MPC-BE.

Click on view->options->internal filters->audio decoders->audio decoder configuration.

Under pass through select AC3, EAC3 and TrueHD (if using ARC deselect TrueHD).

Now back on options menu select audio->audio renderer and select the HDMI output.

See if that works, you may also have to manually select the DD+ track in the video if there is more than one just right click on the video while playing and select the correct audio track.
unfortunately that didnt work. the only player that produces atmos is Microsoft film&tv but its too dark, and there are no manual controls to fix it. its driving me nuts! kodi i can only select 7.1
 

timoat

Active Member
Next problem is, none of the players are showing video the same, some are oversaturated, some under, some have strong contrast, others weak, whats going on?!
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom