• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Problem with Magic Eye / RF2 after new Samsung HD Box fitted.

luke0380

Standard Member
I originaly had a Thomson box, but after moving some furniture around the HDMI port on the back of the Sky Box failed so the original installer came round , and i believe i now have a Samsung Box! (Incidently the box he brought it in was a Black Sky HD Box, not a blue or red or green one!)

Anyway as he unplugged the connectors on the back of the hd box he broke coupler which was connected to the sky hd box , and had to use nose plyers to get it off! (the other end connected to white co axil lead which i have got going to wall socket!

Anyway he had a spare coupler in his van, which i fitted! , however ever since then , when i watch the tv in the other room, the picture all be it okay is nothing like it used to be! , it seems the image is on the screen but i get like a vertical line that moves up and down the page which is very off putting.

I am not sure if he damaged the white lead in anyway (which i had made up by an aerial firm!) or if the coupler he gave me was cheap! or if the RF2 output on the new Sky box is just naff!!Any help in over comming this would be great!

I have switched the RF output on and selected channel 25 i believe!
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom