Problem with Homeplug Adapters


Standard Member
I bought a pair of these:
Twin Pack Highspeed Professional 85Mb / 85 Mbps: Electronics & Photo

The adapters themselves worked perfectly for nearly a month but then one day recently the connection became incredibly slow , like snails pace. Could barely even open the google page, most of the time now it just times out.

I wondered what was wrong so i tested everything and realised that it was actually the socket itself. When i plugged the homeplug adapter into the socket just outside my bedroom the connection was fine and back to its normal speed.

The problem is that i dont like to have some big ol' wire trailing my room, tripping people up, its a bit unsightly aswell.

Im not sure what to do. The plug points in my room work fine for powering stuff. Im not sure how i could fix this, im no electrician (im 17).

Any suggestions would be appreciated.

Thank you (sorry if you have seen this kindof thread 1 million times before )


Distinguished Member
If in anyway a socket seems dodgy you should get it checked/replaced.
But to be perfectly honest it is the simplist thing to change, just 3 wires, but do get the electric turned off first.


Standard Member
I have a different problem. I used the adaptors to connect my Apple TV as with wireless it was struggling to stream video. It has worked fine for almost a year but now has just stopped working. Both devices have the 'power' light lit and the 'ethernet' lit but not the 'powerline'.

I've tried running the utility and it can't detect either of them. I've even tried plugging them into different sockets in the same room but no joy.

Any thoughts or suggestions gratefully received.


The latest video from AVForums

Samsung & LG UK TV Prices 2023; Amazon Fire TV Cube; Calibration Tools of the Trade + AV news
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom