1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with Barco 650

Discussion in 'Projectors, Screens & Video Processors' started by mediamogul, Jun 23, 2002.

Thread Status:
Not open for further replies.
  1. mediamogul

    mediamogul
    Active Member

    Joined:
    Jan 25, 2002
    Messages:
    490
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Chatham,Kent
    Ratings:
    +18
    [Mod Edit : See post 2 for frequent fault]

    I have just bought a barco 650, it was working fine on demo in London. I transported it back to kent with kid gloves.But now it doesnt work their is power to the unit, the fan is on and lights on the boards are alluminated, but the tubes are dead. Anyone any ideas? Is there something that could be dislodged in transit that could cause this problem.Any help would be apprieciated.
     
  2. Roland @ B4

    Roland @ B4
    Active Member

    Joined:
    Apr 11, 2001
    Messages:
    2,238
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Reading.
    Ratings:
    +32
    This is common with the older barcos.
    I suspect you have dirty connection on one of the cards.
    Open the projector and take off the big yellow cover. You will see a row of cards running front to back. Unseat each card and push it back home again. Joy should then be returned.
    Run as much as you can to make sure it is settled.

    The 650 was a very under estimated projector it gives a supurb picture. I hope you'll be happy with it.

    [MOD EDIT : I have highlighted a very frequent fault]
     
  3. mediamogul

    mediamogul
    Active Member

    Joined:
    Jan 25, 2002
    Messages:
    490
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Chatham,Kent
    Ratings:
    +18
    I am now, thanks for the tips. The problem was the remote lead was badly soldered.
     
  4. Roland @ B4

    Roland @ B4
    Active Member

    Joined:
    Apr 11, 2001
    Messages:
    2,238
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Reading.
    Ratings:
    +32
    Or it could be that :blush:
     
Thread Status:
Not open for further replies.

Share This Page

Loading...