Problem since i changed tv

Andyjedi

Novice Member
Hi,
New to the forum and hope this is in the right place.
I need a bit of help as I've hit a brick wall with my set up.
I have an Onkyo TX-NR609 which is working fine but I recently changed my tv from an old 50" Panasonic to a Samsung TU7020 65", my issue is the Playstation 5 works fine through it with surround sound, so I know the amp is working as it will also play dvd's and blu ray but as soon as I connect my laptop I am getting no sound or picture. This was working perfectly till I changed the tv. The laptop will work if I plug directly to the tv but not when in the receiver. I am using HDMI cables. I can't understand why its not working as nothing has changed only the tv. I have the receiver into HDMI 2 eArc? I know the Onkyo is quite old and only has Arc but I thought it was backwards compatible. It could be a setting on the tv I need to change but I have not changed anything on the laptop.
Any help or advice on this matter would be greatly appreciated.
Thanks in advance,
Andy.
 

ShanePJ

Distinguished Member
AVForums Sponsor
This will depend upon what audio you are trying to output.

Ensure you have the setting on the AVR set to ("HDMI Control (RIHD)" setting to "On" - "Audio TV Out" setting to "On")

Check the Samsung website for ARC settings and see if anything is a miss within the TV settings

As far as I'm aware, if you are trying to send anything other than stereo or compressed 5.1 (if the Samsung will output it), then it won't work with ARC

Can I ask which product you are connecting the laptop to? Depending on the settings, it's probably trying to output uncompressed PCM 5.1 which is as I'm aware is not a compatible format for the AVR. You should however be able to plug this into the AVR if you have sufficient HDMI inputs
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom