Problem scanning Digital TV channels on Slingbox HD Pro

itm

Active Member
When I select the coaxial input on my Slingbox Pro HD I get a "no video signal" message, despite the fact that my TV aerial is plugged in. Since I don't remember tuning the channels on it for a very long time (if at all) I thought that might fix the problem. So I looked for a way of doing this via the Slingbox web interface, but couldn't find one. Eventually I found a legacy Windows program called SlingPlayer_2.0.4522_Setup-Global.exe. It's no longer supported by Slingbox (they no longer support any of their older equipment, God bless them), but I managed to find a download link for it. So I ran it, and it gives me the option to reconfigure my Slingbox. The problem is that it doesn't Has anyone else had any luck (re)scanning for digital TV channels on a Slingbox Pro HD?
 

Kurre

Novice Member
Slingplayer Assistent - Configure video source - ANT IN - Next - Antenna - Digital - Next
If you dont have figured it out yet.
 

itm

Active Member
Thanks for your message. The scan did find a fair number of channels, but the signal quality seems very poor when the antenna is connected to the Slingbox - many of the major channels were not detected by the scan (e.g. ITV, Channel4, Channel5, BBC1HD, BBC2HD, ITV1HD. The antenna/signal is fine, as when I connect it to my TV it shows a full set of digital channels.
Watching any live channel via the Slingbox's antenna is impossible - the signal is very choppy and frequently drops out completely. Could the Slingbox tuner hardware be faulty?
 

Kurre

Novice Member
Dont think so, my hd/pro tuner is poor as well but not that poor.
I might have a stronger signal.
I have used it looong ago and it was OK.
 

itm

Active Member
The Slingbox is definitely having issues with the antenna signal...if I connect the antenna to the Slingbox, then connect the antenna out from the Slingbox to my TV, the TV shows little or no video signal. If I disconnect the antenna from the Slingbox and connect it directly to the TV the signal on the TV is perfect.
So the Slingbox antenna/tuner connection is causing some sort of issue.
 

Kurre

Novice Member
Or, you have a weak signal and the TV has a much better receiver.
PRO / HD is well> 10 years old and I think your TV is significantly younger.
I have 20 km (13 mi) to my transmitter and a big antenna on my roof and therefore I have no problem with the signal.
Try an antenna amplifier and put it where the signal is strongest, near the antenna, otherwise you amplify both signal and noise.
 

itm

Active Member
I also have a TalkTalk Youview box and it can get a good signal (and full channel listing) from the same antenna. I guess the Slingbox receiver isn't that great
 

Kurre

Novice Member
I never use Slingbox tuner, bad software with no organization of channels and it takes in pay channels which it cannot show and poor on-screen remote.
I want to change my Slingbox M1 to a PRO / HD with or without tuner because when Sling Media ceases its server you can go directly to the boxes with Slingplayer 1.5.x.
 

Bob1954

Member
I just tried to re-tune one of my slingbox pro hd boxes. I use slingplayer 2.0.3.508 on windows 10. It always used to configure the box fine, I have not tried for many months, but today, the settings never open, then a message saying that I need an internet connection. Internet is working fine and slingplayer can view the box without issue, only the configuration does not work. Suspect the sling have removed this at their server end. Using one of the new (web based) slingplayers, I could re-configure. But I absolutely hate the web player! They really cheese me off!
 

The latest video from AVForums

Podcast: New Denon AV Products, HDMI 2.1, 8K, DTS:X Pro Sound Q&A with Denon Product Specialists
Top Bottom