1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pro with Samdung HD950/Hitachi LD7200

Discussion in 'LCD & LED LCD TVs' started by aftertaste, Oct 24, 2005.

  1. aftertaste

    aftertaste
    Active Member

    Joined:
    Mar 16, 2005
    Messages:
    1,176
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +95
    Hope someone can help with this problem.

    I have the Samsung HD-950 connected to the Hitachi LD7200 via HDMI. But all I can get as a picture is a frozen white noise type of thing....

    I've read about this before, and often it just requires you to turn off the DVD player and turn it back while the TV is tuned to the HDMI channel. It's not fixing the problem though.

    Anyone know what I do to fix it?
     
  2. mike7

    mike7
    Well-known Member

    Joined:
    Jan 3, 2005
    Messages:
    4,546
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Norwich
    Ratings:
    +488
    I bought a HD 950 at the weekend. Still waiting for my LCD order to come through. On the box is a sticker
    "Due to the numerous features of this machine, if you experience difficulties during set up, please call our troubleshooters on 0870 900 1000 (national rate)."

    Incidentally there is another sticker which gives the multi region hack.

    Hope this helps
     
  3. aftertaste

    aftertaste
    Active Member

    Joined:
    Mar 16, 2005
    Messages:
    1,176
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +95
    Thanks for the reply.

    My player is multi-region hacked. I thought it might be the problem.

    After trying The Village DVD about 50 times, stopping, starting, ejecting, turning off etc. I tried another DVD. For some reason it just played, and now they all do. God, audio/visual equipment can be puzzling sometimes.
     

Share This Page

Loading...