Prima LC-40T7 with Samsung LTA400W2

D

duo

Guest
This is my first post as AVForums, so hello all, I hope this goes well.

I have acquired a somewhat dead Prima LC-40T7 LCD television/monitor with a dead control board. The power supply and backlight work properly (I reverse engineered sufficiently to determine this).

I've found that the control board will start its power-up sequence when the power switch is toggled, but after that it seems to get stuck. It will not power back down and does not activate any of the external boards such as the backlight, LVDS driver, etc. The larger of the two Pixelworks ICs gets rather hot, perhaps this is a problem or it's normal, I don't know.

I checked every power supply rail I could find, 5V, 18V, 24V, 3.3V, 1.8V, 2.5V etc and they're all fine and show no abnormal ripple.

What I'd like to know now is where I could find another board for this set, either the original type, or some other LVDS board that works with this Samsung panel as I'm sure there are plenty that will. I'm not overly concerned with what inputs I get as long as I can have VGA and composite(better if S-video and/or component) HDMI not necessary.

Does anyone have any information on this or pointers to other threads about the Samsung panel? (I will search this myself. I don't intend to bother anyone if I can help it as I'm sure many of you have been over this).

Thank you.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom