1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PriceJapan return insurance?

Discussion in 'Projectors, Screens & Video Processors' started by jamesdoc, Jan 18, 2003.

  1. jamesdoc

    jamesdoc
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I am ordering an AE300 this week and was wondering whether to get the 30 day replacement shipping. How many people have actually had to send their pj back? My thinking is that the AE300 is basically fairly reliable, so hopefully it should just be ok. For those who sent it back from either Aus or NZL, how much did it cost?
    Thanks for your help.
    james
     
  2. Harb

    Harb
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    G'day,
    I paid for it, and had to use it as well.........
    I have the new AE-300 in the HT now and it is just fine so far, but I have paid for another round of the insurance just incase.......
    The other thing is, it makes the return very easy.
    you just take the package to DHL, and quote them the number Kaneda gives you and thats it.......away it goes.

    Lets hope you don't need it!!
    But as with all things electronic.....you never know.

    Cheers
    John
     
  3. Kramer

    Kramer
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    So what was the problem with your first AE300???

    Not pixel trouble according to another thread. Just curious as to what warranted a return.
     
  4. snocrash

    snocrash
    Standard Member

    Joined:
    Dec 27, 2002
    Messages:
    103
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +1
    $200 to Japan. $200 to AU. = $400 if something goes wrong in first 30 days.

    ship-back option = $150 return trip.

    I reckon its cheap insurance. I paid for it.

    You're already saving so much by importing the unit, don't let anal tightness give you pain lest something breaks.

    ($ are in $AU)
     
  5. Harb

    Harb
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi snocrash,

    Never Did find out the real problem, just the "Red led of death"

    Anyway the new one has got close to similar hours on it now with no problems so far......thouch wood
    I am running the thing on 110v this time round and it seems to be happy with that.
    I'll keep you posted.

    John:)
     

Share This Page

Loading...