PowerDVD Ultra problems

Gae

Novice Member
I've had PowerDVD Ultra for a few months and I've been playing my HD DVDs fine up today. I run the XBOX 360 HD DVD drive via my PC.
Today though, when I popped in my Lovefilm HD DVD rental of "Flags of Our Fathers", all that came up was a black screen and the information was showing a 1.0 mono track etc. I tried one of my HD DVD's "The Road Warrior", which I only watched a fortnight ago and the same thing. I tested it on some Mpeg files on my computer and they played as normal. Then I tried some of the EVO files on my comp that I'd ripped from one of my HD DVDs and Power DVD Ultra crashed. I reinstalled the software but still the same. It seems to be a problem with Evo files for some reasons. I've made no hardware changes at all since this happened. The only thing that's different is that I'm using the S-Video out of my Graphics card at the moment. I usually go to "single VGA display" mode whenever I watched HD DVDs anyway. I dont know why this has happened all of a sudden with Evo files. It's so annoying.

Any ideas please?

Thanks in advance

Gae
 

The latest video from AVForums

Podcast: Philips OLED+935 impressions, Denon AVC110 Review, Film Reviews, News and More...
Top Bottom