1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Power problem with Fujitsu 4214

Discussion in 'Plasma TVs' started by too_laid_back, Mar 31, 2005.

  1. too_laid_back

    too_laid_back
    Standard Member

    Joined:
    Sep 30, 2002
    Messages:
    38
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Essex
    Ratings:
    +1
    Hi guys...

    I have an 3yr old 4214... that has started to power it's self off, for no reason. The power on switch is flashing amber. I normal fix this by switching the screen off for 30 secs, then power back on ok.. This prob works for a few hours, then back to the flashing amber light again.
    First thought it could be fuses or spikes, but i have changed all the plugs & put in an surge protector. :confused:

    Any ideas???... or contacts for an repair place for them to check... :lease:

    Thanks for the info guys!!!
     
  2. MAW

    MAW
    Banned

    Joined:
    Jan 24, 2002
    Messages:
    14,082
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Nr Dorking
    Ratings:
    +412
    It's your power board, a repair is feasible, if you get a silly quote off Fujitsu, let me know, PM or something. I know a guy who is capable of sorting this.
     
  3. shisler

    shisler
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I too have a Fujitsu P42HHA10Es that has the on/off flashing. I bought in Europe and noe in the States and need a power supply board. Pretty sure that is the fix. Anyone had this problem and had it fixed?
     

Share This Page

Loading...