Possible Faulty 65FZ950 OLED Series

jerrej

Standard Member
Faulty Panasonic 65" OLED TX65FZ952B

I have an issue with this system and came here to make sure nothing stupid has happened that I haven't noticed.

DIgital TV Tuner shows signals but produces no audio/video (rescanned) black screen overlay works
USB I/P wont play videos hard drive usb sticks black screen overlay works
Netflix no video/audio black screen doesn't even go to main screen
PS4 AV HDMI4 no video/audio black screen

The only thing that works is Amazon Prime from shortcut all work perfectly streams perfectly audio/video

Something is up here, any help will be appreciated.

I do have 5 Year warranty purchased 20-07-19 but will check here first.

Cheers all.

Jerry
 

zircon3035

Member
My 65FZ802 did a similar thing two weeks ago. It lost all Freeview and Freesat signals. the tuning display showed 100 percent signal strength but zero quality but nothing could be tuned in. Prime, Netflix and YouTube all worked fine. I called TPS (where I ordered the tv) and they gave me the details of a local dealer who came out to check the set and return it for service.
Two weeks later it was returned repaired. The note from Panasonic says the A-pcb was replaced. Hope this helps,
 

jerrej

Standard Member
My 65FZ802 did a similar thing two weeks ago. It lost all Freeview and Freesat signals. the tuning display showed 100 percent signal strength but zero quality but nothing could be tuned in. Prime, Netflix and YouTube all worked fine. I called TPS (where I ordered the tv) and they gave me the details of a local dealer who came out to check the set and return it for service.
Two weeks later it was returned repaired. The note from Panasonic says the A-pcb was replaced. Hope this helps,
Hi zircon

Thanks, sounds very similar, time to contact Panasonic, knew was best to start on here.

Cheers I'll give an update once concluded.

Jerry
 

zircon3035

Member
Jerry, when you contact Panasonic, don’t forget to ask for a copy of the extended warranty document, if you don’t have it, as the dealer will want a copy.
 

jerrej

Standard Member
Hi all

Good news, The TV is back up and running all issues resolved.

Spoke to Peter Tyson & Panasonic UK all gave suggestions on what to try, so pretty much remove all inputs, system reset, check for updates, turn off, added inputs one by one, turn off rinse & repeat.

I do have some other issues but that's regarding my warranty, myself, Peter Tyson & Panasonic UK will try and resolve this.

Other than that, very happy.

Cheers
 

The latest video from AVForums

AVForums Movies Podcast: Which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom