Populating iTunes from NAS

mr:w

Well-known Member
Not sure if this should be in network area or here......

I've got all my MP3s on my NAS, which I can access no problem. I've set the NAS share location in iTunes Preferences > Media Folder Location.

Now what do I need to do to make all my MP3s visible in iTunes without copying them all locally? Also I assume once all my tracks are showing in iTunes I can sync them to my iPhone?

Apologies if this has been covered before, couldn't find anything similar when i searched
 

lord-dudester

Well-known Member
mr:w how are you sir!?

right, yeah, once they're all in itunes you'll be able to sync no problem, but you gotta add them to your itunes first

i think although you've got the pathway right to where your music is you've still got to manually 'add' them to your library

if you go > File > add to library

can you navigate your way to the folder that holds all the MP3's?

if not can you navigate to the main folder of where all the MP3's are? if so you can obviously just drag and drop it on the library list on the left of the main itunes window

this 'should' cough cough, add them to the library but keep them in the current location
 
Last edited:
Done the first possibly correct...I would use iTunes to keep the media folder organized to make your life easy...

So point the media folder to the NAS but in a different location than where the MP3's are...Then ensure to tick Keep iTunes Media Folder organized and Copy files to iTunes Media folder when adding to libray...

Then have iTunes open, navigate to the folder on your NAS where currently all the MP3 are...Then select them all and drop on top of iTunes....iTunes will then organise them properly underneath the folder selected earlier...Once complete you can delete you 'loose' MP3's....
 

mr:w

Well-known Member
mr:w how are you sir!?

i think although you've got the pathway right to where your music is you've still got to manually 'add' them to your library

if you go > File > add to library
All good thanks fella, will be even better when I manage to get this sorted :smashin:

It was the file / add bit I'd not done, set it to run last night and it was still ploughing through them this morning - got a few hundred Gb so it could take a while......

@dejongj - very useful, thanks - will see how I get on with the approach above and if it doesn't give what I want I'll try your method :thumbsup:
 

The latest video from AVForums

Podcast: Marantz SR7015 & NAD T 778 AVR + Mission LX2 MKII Speaker Reviews, AV & Film News and More
Top Bottom