• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Popping/crackling noise from surround speakers with Humax Foxsat HDR source

DaddyR

Established Member
I've had an Onkyo TXSR608 in place for about 2 months. It outputs to a 7.1 speaker system.

Yesterday, for the first time ever, the audio coming from our Humax Foxsat HDR (connected by HDMI) had a quiet but obvious popping/crackling sound in the background. It was very obvious when the rugby was on (as it happens with all noise, and there was lots of background noise in the rugby) but also noticeable with other live programmes and recordings. The sound was most noticeable from the centre, left side and left rear speakers but was present through all speakers.

The crackling/popping wasn't there with other sources (CD, Bluray). Switching the Humax HDMI to a different connection on the rear of the Onkyo didn't resolve it. In a fit of pique I switched the HDMI cable back to the original connection and the problem mysteriously stopped!

My thoughts are this, can anyone shed any light:
  • The HDMI cable is failing - it was a cheap one from Asda going on the theory that expensive cables are no better, maybe not in performance but possibly in craftsmen ship!
  • The Humax box is failing - I really don't want this to be the case
  • I am going mad (although my wife claims to have heard it at the same time to)

Is there anything else I should consider?
 

logiciel

Moderator
It has to be the cable surely!
You don't need to pay much for a new one though - the theory is correct.
 

The latest video from AVForums

CES 2023 Round Up: New TV Lineups for 2023 from LG, Samsung, Panasonic, Hisense & TCL
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom