• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Plv-z2000

richardglazer

Standard Member
Stopped working after one day. Not sure what the issue is...

Appears to turn on with a "very" dim light but cannot get anything to display nor does any remote or menu options work. Appears to be "hung" and non responsive. Only way to turn off is via the switch. After a few minutes it can be turned on again via the remote or set top switch but the same condition exists... EXTREMELY FRUSTRATED and would really consider returning at this point. I had reservations about buying anything that is Sanyo or has the Fischer name on it. It appears I should have not compromisted quality to save a few bucks... Not sure how the return will go as I have already sent in my rebate. Anyone have any ideas or thoughts as to what the issue may be? How about the rebate debacle? Will I still be able to return seeing I cut the code off the box.
 

sarll

Established Member
Stopped working after one day. Not sure what the issue is...

Appears to turn on with a "very" dim light but cannot get anything to display nor does any remote or menu options work. Appears to be "hung" and non responsive. Only way to turn off is via the switch. After a few minutes it can be turned on again via the remote or set top switch but the same condition exists... EXTREMELY FRUSTRATED and would really consider returning at this point. I had reservations about buying anything that is Sanyo or has the Fischer name on it. It appears I should have not compromisted quality to save a few bucks... Not sure how the return will go as I have already sent in my rebate. Anyone have any ideas or thoughts as to what the issue may be? How about the rebate debacle? Will I still be able to return seeing I cut the code off the box.

U have brought something that doesn't work, don't consider sending it back, send it back!!! :suicide:

I own the same unit and have zero problems with it. There isn't a product that's ever been made that has a 0% failure rate! Sounds like bad luck.

You mention rebate, are you from the US? In the UK if something is faulty you can return it and expect a refund (within a short time) - also you get a 3 year warranty.

Also the manual explains many of the different error modes that can occur (ie blinking red lights etc). Try looking......

Good luck!
 

Bonesy

Established Member
I agree, this is my second sanyo, and works fine.
better if breaks at the start, than in the middle of ownership.
sanyo's warranty implies they're probably as reliable as any other out there.
send back, get another, and if that is also faulty, then get wound up.
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom