Please plug in your VR headset (Reverb G2)

empleat

Member
There is no manual, even online! I found this great guide, how to setup Reverb G2:
On HP official site, Quick Setup Guide page doesn't even exist... HP Reverb G2 Virtual Reality Headset Manuals | HP® Customer Support

There is only 1 paper, where cables go on and nothing about how to connect cable to the HMD... Which is stupid, you can damage your HMD, if you connect it incorrectly!

From that youtube guide, i was able to connect cable to the HMD. I heard click and when i push it more, it seems it is fully in and holds there firmly! So i am 99% sure it is connected!

I am on ASUS Z390-i gaming, i enabled Legacy USB support in BIOS. I am using USB3 port to connect HMD. I have USB speakers detected, so USB is connected just fine! I connected display port to gpu. And cable to an outlet. Nothing popped on! I went to the steam and launched WMR, it says: please plug your VR headset!

I am on Windows 10 pro x64 20h2. No idea why it is not working, all cables are connected! I have WMR for steamvr... Also no new device is in device manager. I already tried restart.

Please help!

EDIT: LMAO someone said use USB 3.0. But my motherboard doesn't even have 3.0. Only 3.1 Hope that's not it

He also said: to not use USB 3.1 gen 2. I tried USB 3.1 gen 1. and still no headset detected!

EDIT: hololens sensor is working properly and has drivers installed 21/6/2006 from Microsoft. Windows said, i have already best drivers for this device...

ALso set my pci-e to gen3 and it is reporting in GPU-Z to be gen 3...

BTW: what is weird thing: i heard there should be some USB hub too, but i got nothing like that in package, only USB-A to USB-C reduction. Also cable is not 6m, it is like 3m wtf, feels short as hell!

QUESTION: any video how to reseat cable properly. It is fully in and almost nothing to grab it by and i have huge hands, i don't want to break it. But it should be in fully. I heard click and it is fully in and holds there firmly. After click i didn't apply additional force! I just want to try it..

EDIT: HP staff supposedly said to not uplug it ever, so that's off the table, but i heard click, doubt that's it!!!

MRTV said: that usb hubs helped. But it has to be active one and powered, i couldn't find any in my country so far and i have only 13 days to return it. God knowns if i will be able to get some. And i already spend like 60 eur for batteries, now i will need frankedmod yet and godknows what. Yet spending another 50 for USB, if it even helps. I don't have time to get tah tested one from amazon... And if ordered that ahead, then i wasted 50 for nothing maybe... I supposed i will be able to test it when it comes first... It is stupid for user to be forced by 10 things ahead to be be even able to test it...

SOLVED: Don't know what i did, i reconnected headset one more and it light up and got mixed reality popout from store on screen.
 
Last edited:

The latest video from AVForums

Toy Stories - Turning Toys into Blockbuster Movies
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom