Quantcast

Please Help..

[email protected]@y

Standard Member
Just bought a Multi-Region Tosh SD220E from Richers.
I have it connected via S-video to a Philips 28" DVB TV.
When I play a region 1 disc (i.e. Insomnia) I can only get a black and white picture
Ive checked all AV channels (y/c) but they are all B&W and 4:3 ratio
Am I missing something?
When I connect my PC's Creative DXR3 DVD decoder card to the same TV and play insomnia , its colour?!!?!

Please Help :(
 

mjn

Distinguished Member
Your dvd player is outputting a NTSC signal (R1), make sure your TV can accept a NTSC signal. If it can't then it will display a black and white picture. Also make sure you're using the correct input on your TV.
 

groundy

Standard Member
Make sure the DVD player's Video System is set to Auto in the Video Set-Up Menu. I think the Tosh can be set to PAL, NTSC or Auto.
 

[email protected]@y

Standard Member
Sorted it...using RGB scart instead and it works fine
Thanx all
 

mandlebrot

Standard Member
Groundy: He must have the setting right (which by the way is just PAL or AUTO) cause the Tosh refuses to play R1 Disc if it’s set to PAL.

Mjn: Can you connect it using a scart and if so will your TV accept RGB, if it will then this will give you colour.

When you use your PC to play R1 DVD's it must be converting it to PAL before sending it to the TV but the Tosh can't do this so your TV must be able to accept NTSC or RGB in-order to get colour. If your TV is incompatible with these then you would be better exchanging the Tosh for something that can convert to PAL. Most players that were designed has multi-region can do this, unfortunately the Tosh was only designed has single region and then hacked to multi so this feature was never built in.
 
Top Bottom