1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please help sony STR DB930 problem

Discussion in 'AV Receivers & Amplifiers' started by RaptorRed, Jan 14, 2005.

Tags:
  1. RaptorRed

    RaptorRed
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I was running a bass test track through my sony strdb930 and i foolishly turned the volume too high and it stopped making any sound and flashed prottect at me, so i opened it upand noticed two blown fuses in the power supply area, they where 20mm quick blows rated at 8A, as these turned out to be difficult to fing i soldered two 4A one on top of the other and replaced them, after a factory reset all was fine until i tried to listen to some music, now i just have to say that i use my pc as my primary soure and connect using a digital optical TOs link , the audio was very distorted and i first thought i had blown the speakers but eventauly tracked the problem down to the rear chanels bleeding into the fronts, therealy odd part is that if i feed the amp a dolby digital signal then there is no distortion even when the rears are enabled, so does anyone have any idea what the problem is and how it could be fixed, side note i use banana plugs so is not crossed cables and problem persists if nothing plugged into rear channels.
    thanks in advance
    Raptor Red.
     
  2. pjclark1

    pjclark1
    Well-known Member

    Joined:
    Jul 19, 2004
    Messages:
    4,411
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Thailand
    Ratings:
    +271
    restore factory settings on amp, then try again
     
  3. bob1

    bob1
    Well-known Member

    Joined:
    Nov 7, 2002
    Messages:
    4,324
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Sheffield
    Ratings:
    +129
    Using 2 4 amp fuses does not make it a 8amp,take a look HERE , but you should be able to pick them up at maplins.
    Can't help you with the problem ,i would also sugest a reset but you have done that, looks like something as gone pop.
     

Share This Page

Loading...