please help cable problem

M

mp14d

Guest
I have a modest jvc all in one system (th70) and had really cheap manufacturers cable wired up to it.

I went out to currys today and bought £90 worth of monster cable(really thick stuff) and my system never sounded so bad from all but the centre there is a weird sound coming from yhe speakes, its hard to describe but sounds like the sound waves are all broken up.

As i say the centre is fine and i am thinking that it is because it has the shortest cable run, could it be that the cables are to much for the system the shortest affected run is about 3 meters and the longest about ten meters.

Please help as i dont know what to do and have just gone and blown nearly a ton.
 

Ian J

Banned
I'm afraid that I don't know the answer to the problem but my own feeling would be that upgrading the cable would have little or no effect either positively or negatively and wonder if the problem lies elsewhere.

If you still have the old cable try putting it back piece by piece and see if you can isolate the problem that way.
 
D

damtom1

Guest
Have wired the speakers properly?....Positive and Negative connected properly,(sounds obvious ,but i've done it many a time).....could be a connection problem,i'd check all the connections.
 
M

mp14d

Guest
so theoreticly speaking if you put a thick £20 per metre cable on a cheap system it shouldnt sound any worse than a £0.50 per metre cable.

I dont really understand all this but what about resistance?
 

Stereo Steve

Novice Member
Thicker cables will actually pur less strain on your system as they have less resistance. As already advised, check you have them wired right and double check that there are no strands of wire touching connectors that they shouldn't.
 
M

mp14d

Guest
after playing about a bit changing cable etc i have discovered that the cable is fine ,speakers are fine the problem only occurs on pro logic 2

any suggestions
 

Ian J

Banned
Changing the speaker cables shouldn't affect Pro Logic 2 unless it affects all the other sound modes too. Has PL2 worked satisfactorily in the past ?
 
M

mp14d

Guest
pro logic 2 was fine until i changed the cables,i am now thinking about buying anew system if my wife will let me.

i am going to scour the classifieds

thanks for all yor help
 

Ian J

Banned
have a look at Richer Sounds website too here

If your wife puts her foot down start by checking all of the other connections on the JVC as something may have come loose or a loose wire may be touching another
 
M

mp14d

Guest
just sold my jvc to some guy at work and placed an order for the sony davsc8 (£539)

happy days !!!!!
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom