Playstation 3 HDMI Nightmare

The Maverick

Standard Member
Hello All,

I'm not too sure where this belongs here to be honest so I apologise in advance if this is incorrectly placed.

My PS3 was setup to output to my monitor via HDMI through a DVI converter. It has worked perfectly for about 9-12 months.

A few days ago I turned my PS3 on having used it perfectly fine earlier in the day only to find that the screen was black. But the light on the monitor was blue indicating a signal. I have tried other cables (both different HDMI cables and an entirely new HDMI/DVI cable), have reset the PS3 and even went into safemode and fixed corrupted errors. There is still no display and the light still turns blue... I contacted Sony who are demanding £110 to have them ship me a refurb (which I told them straight was outrageous to which the man on the end of the phone got very rude). This is now my 3rd PS3... I have forked out loads of money these past few months on games... Christmas is around the corner which means the few I haven't got will probably be under the tree... I really really need a solution if anyone has one.

The monitor works for certain because A) It worked with the PS3 before and B) I'm using it right now with my PC.

Please please please help =(

Yours,

> Mav
 

RottenFox

Distinguished Member
Try the ps3 on a tv, not a monitor, with hdmi, and see if it works.
That'll go somewhat to answer your question as to what connection is faulting.
 

The Maverick

Standard Member
Thanks for the reply.

I sadly don't have access to a TV with an HDMI port... However, if I do get one, and it works, then what? I nevertheless need DVI support =(
 

hippo99

Distinguished Member
Thanks for the reply.

I sadly don't have access to a TV with an HDMI port... However, if I do get one, and it works, then what? I nevertheless need DVI support =(

Yes, but if it DOESN'T work with HDMI on a regular TV, then at least we know the problem is on the PS3 end & can start suggesting different solutions for you to try- maybe dodgy HDMI port, accidentally changed to wrong display setting on PS3 etc.

Also could try connecting PS3 to your TV using composite (red, yellow, white) lead to establish if your PS3 is even working.
 
Last edited:

Foster

Distinguished Member
Yeah hippo99s suggestion of hooking it up with the composite is a good idea
 

RottenFox

Distinguished Member
Yeah hippo99s suggestion of hooking it up with the composite is a good idea

Still won't sort out whether or not his hdmi port/ps3 isn't sending a signal/working correctly.
If composite works..fine, but maybe hdmi still doesn't, hdmi sockets do crap out.

Take the PS3 to a friends house, one who has hdmi on a telly, and test it, then you will know more.
 

The Maverick

Standard Member
Thanks all.

The PS3 certainly works through the composite cable. It was the only way I could access the safe mode. There's certainly something dodgy about the port I reckon... I will ask a friend of mine whether he can test it at his house for me. I will get back to you all in a few days. Really appreciate the input thus far =]

Edit: By the way, if I went back into SM and clicked "Restore default settings" would that also erase all save data etc?
 
Last edited:

The latest video from AVForums

Podcast: Trinnov Room Optimiser: A full explanation of Trinnov and its room optimiser technology
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom