Playing 4K files from Plex Server Issues


Novice Member
Playing 4K files from Plex Server Issues

Hello and apologies if this question is in the wrong place or already asked, I spent some time looking on the site and couldn't find a match

I'm hoping someone with the know-how or knowledge can either point me in the right direction or even help me troubleshoot the problem.

Basically I am trying to play 4k video files from my Plex Server with the files themselves stored on my NAS. Some files work great and others just stop/start every second (I presume buffering?) but I have no freaking idea why. I have set Plex to prefer to 'Direct Stream' as I feel that transcoding will create more issues (?) So I don't know if it's a bandwidth issue on my LAN? My CPU not powerful enough? Not enough RAM on the plex server? File type issue? I really don't know. Some files make my cores hot and I get warnings. Other files seem to just work?

The specifics:

Plex server - 64-bit Win 10 Pro i7-8700 CPU @ 3.20GHz 3.19 GHz with 16 GB RAM
NAS - Synology DS 1821+ running DSM 7.0-41890
TV - Samsung TU8000 55" UHD 4k (2020)
4x4 HDMI Matrix Switcher (PS4 Pro plays file with Plex app (client) via switcher to 4K TV)
PS4 Pro (seems to play more files than the Shield)
Nvidia Shield (struggles to play most files tested)

By way of example I have added some screenshots of my plex server whilst playing a test file that works and 2 others that don't in the hope someone might see something that has so far eluded me and might say; "Ah-ha!"

Screenshot explanations as follows:

non-working file test 01: This file just won't play. Bandwidth seems to be topping out but I've really got no idea how to interpret the graph
non-working file test 02: Different movie but same issue. It seems to want to transcode it but I'm not sure why
working file test 01: Different movie and works relatively well. If I was super picky it's not as smooth as I'd like it on screen but others I showed couldn't pick it

If I've left something out or more data is required please feel free to get back to me. If you have a suggestion or can pinpoint an issue can you please use laymans terms as I am not very technical!

Thanks in advance and thanks for reading



  • working file test 01.jpg
    working file test 01.jpg
    104.5 KB · Views: 259
  • non-working file test 02.jpg
    non-working file test 02.jpg
    119.5 KB · Views: 198
  • non-working file test 01.png
    non-working file test 01.png
    212.1 KB · Views: 196


Distinguished Member
Test playing the files without using Plex and see if it makes any difference,

Create a "bog standard" SMB Share on your NAS, drop a couple of the "bandit" files into that and then try playing the files from those shares without using your PMS.

That will establish a few things including; whether the client devices (TV, Shield, et al) can render the media - ie are they capable of decoding them, and whether the network pathway has sufficient bandwidth.

If it turns out your client devices cannot render the media themselves, then I suspect in your normal regime "something" must be real time trans-coding them notwithstanding that Plex is set to "Direct Play." (Not that I know Plex.)

Playing direct from an SMB share eliminates any chance that your PMS is real time transcoding (you could even turn your PMS off to be sure.) If the media is not compatible with your playback devices, when playing from an SMB share chances are they will just refuse to play it entirely.
Last edited:
Upvote 0


Distinguished Member
I am not sure why but its transcoding the second file according to the picture. The third file you are using h.264 when for 4k you might want to using h.265.

You can run perfmon on your PC to see if its struggling with playback. I assume you don't have a graphics card in the PC ? The i7-8700 does have HEVC support so not sure why its transcoding.

Another quick test, try playing back the content with either VLC or Kodi using a mapped drive to the NAS
Upvote 0


Prominent Member
How are your clients connected to your network? wifi or ethernet? not sure why your shield would be having problems playing most files tested as I have yet to find a properly encoded file that mine can't play
Upvote 0


Prominent Member
Make sure it is all hardwired if possible or have a wifi connection to the access point.

Nvidia shield tv pro (not the tube version) can playback everything perfectly as I have one and run both plex and emby servers from my nas. No issues with 4k.

On you clips it's seems like PlayStation can't playback 4k hevc hdr files hence the trancode and the other ones will hit cpu as you are trying to trancode the the audio as it can't play it back through you device and TV.
Upvote 0


Established Member
Your NAS should be well enough I run the QNAP 472XT and stream happily around the house to LG OLED etc most are Hardwired however some are wifi
I Run an Alien AmpliFi mesh wifi for all the crud we have Alexa washing machine etc. what I have seen is only the XBOX sometimes struggles and I think it’s the client rather than the network but I mainly use native Plex apps on the TVs or Apple TV
Upvote 0


Standard Member
I have a shield and it was running perfectly till just before Christmas and now does exactly what you describe its transcoding films that were working perfectly a week ago I can only assume the latest plex update has buggered it up, network it 10gb everything wired the TV's will happily direct stream the same films Shield will no longer play and tries to transcode
Upvote 0


Standard Member
Ive eventually fixed my problem which looks like 2 problems, to find out what's happening by playing a 4k movie then going to info on the right hand side of the player it told me it was transcoding as far as shield was concerned the amp wasn't capable of playing TrueHD i played with all the connections changed a HDMI cable rebooted and that sorted that problem, it was also complaining the network didn't have enough bad width and was limited to 20000 so i changed the network cable, unticked Enable Relay in network settings rebooted the shied and it was back up and running like before.
Upvote 0

The latest video from AVForums

⭐ Bowers & Wilkins 600 S3 Home Theatre Speaker System Review
Subscribe to our YouTube channel
Top Bottom