1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Playback Glitch on Well Specced PC

Discussion in 'Desktop & Laptop Computers Forum' started by pc99, May 25, 2001.

  1. pc99

    pc99
    Active Member

    Joined:
    Feb 28, 2001
    Messages:
    255
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Milton Keynes, United Kingdom
    Ratings:
    +3
    Hi,

    Can anyone stop me from giving up on my PC and reverting to a standalone DVD player.

    I have a fairly well specced machine:
    Duron 800, 256 MB PC133 SDRAM, Abit KT7a MB,
    Matrox G400 Dual Head, Toshiba 12 speed DVD,
    Guillemot Maxi Sound card.

    I get an excellent quality picture on my projector (Toshiba MT1), running at 1024 * 768 75 Hz. But it drops frames every now and then (about every 20 secs).

    DMA is enabled on the DVD rom, I have the latest MB and Matrox BIOS updates and drivers, DVD genie V4, and have tried the Matrox DVD played, WinDVD and PowerDVD. All give the same results.

    The matrox card is not sharing an IRQ with anything else, and all Virus scanning and other background processes are turned off.

    In short I'm stumped, I assume I should get perfect glitch free playback all the time.

    Any help greatly appreciated.

    Regards - PC99
     
  2. Metric

    Metric
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    dont know about the duron, but others may have it. I have a athalon 600 which suffers the same drop out, in the end i opted to order a p4 1.7 dell.

    Looking at your spec, i notice you have a matrox card. Matrox dont have motion compensation which can take about 20% load off the cpu...i would suggest trying a nvidia or ati radeon card


    M
     
  3. Stuart Wright

    Stuart Wright
    AVForums Founder Staff Member

    Joined:
    Jan 24, 2000
    Messages:
    13,733
    Products Owned:
    6
    Products Wanted:
    2
    Trophy Points:
    167
    Location:
    Birmingham, UK
    Ratings:
    +9,404
    I have the same problem. Other causes discussed are that NTSC is not actually 24 fps, it's 23.9 something.
    So 72Hz may not be the right frequency for completely smooth playback.
    71.9 something would be closer.
    Also is the timing of the graphics card spot on? If it's out, then despite it reading 72Hz, it could be different.
    For example, my projector reports 77Hz !
     
  4. pc99

    pc99
    Active Member

    Joined:
    Feb 28, 2001
    Messages:
    255
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Milton Keynes, United Kingdom
    Ratings:
    +3
    Thanks for the replies.

    You've given me a few things to try.
    I'll report back if I have any joy.

    I'm using DirectX 8 but I'll try 8a. And
    I'll play around with the BIOS and power management settings.

    Fulabeer, I tried 800X600 but found jaggies much more noticable at this resolution. Of course this may be down to the card. I'm reluctant to spend more money on upgrading the card, if I can't be 100% sure it's going to resolve the problems.

    Jenz, just to confirm that the problems happen on a monitor as well. By the way, love Bullets & Babes.

    Spectre, my projector is reporting 75Hz, which is what I've set.

    I assume it's best to set refresh rate as high as possible.

    Cheers PC99
     
  5. Metric

    Metric
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    took delivery of my dell today, its screen is set to 60hz and is running smooth so im not sure the refresh would have anything to do with it. Def try the directx upgrade but i still think the duron and matrox are not enough

    Mike

    PS dell came with a gts card, but it doesnt have dvi support for the flat panel, ive also got a wintv pvr on order but would the all in wonder do a good job as a single card solution?
     
  6. dUnKle

    dUnKle
    Well-known Member

    Joined:
    Jan 1, 2001
    Messages:
    13,366
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Ratings:
    +1,319
    Whilst your PC is of a very good spec your graphics card is now getting slightly long in the tooth. Your DVD encoding is going to have to rely hevaily on not only your CPU but also the memory in your machine.

    I have seen PCs with processors of no more than an AMD K62 550 and 256MB of memory provide almost glitch fre playback and so maybe sugest that some tweaking is in order.

    Im going to take a wild guess and say that your graphics card is not going to be a huge help in playing of your DVDs but your CPU and memory should be more than enough to get the same glitch free playback.

    Go to WWW.TWEAKFILES.COM and look in the files labeled MEMORY. Download a file called CACHEMANAGER. Once installed this will manage not only your virtual memory but also other forms of cache memory including that of your DVD drive.

    Windows is notorious for wasting memory ( I have 512MB of 133MHz RAM but still find that using cacheman gives me a HUGE performance increase ) and you may find that this is were your problem may be if you PC is working in software mode.

    Also look at the simple thing of defragging hard drive.

    Also make completly sure that ALL programs are disabled, use CTRL+ALT+DELETE and you should have EXPLORER and SYSTRAY loaded. Besides you DVD software and CACHMAN ( if you use it ) this is all you will need loaded.
     
  7. Paul D

    Paul D
    Well-known Member

    Joined:
    Dec 27, 2000
    Messages:
    2,620
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Location:
    Manchester
    Ratings:
    +391
    You should'nt be getting any frame drop.
    The system spec is more than enough.

    Since you have checked DMA/virus/screensaver are not causing the problem, i would try Direct X 8a. I've heard people have found small glitches like yours dissappear!.

    Also check in Bios that the settings are correct ie "Plug and Play aware OS" is enabled etc.

    I used to run windows at 800x600 with my MT1z (native panel resolution) as i found the picture sharper. The software player sets the resolution needed.

    Using a HTPC with the MT1z the pictures were stunning, and it also got rid of the faint vertical lines.

    Good luck...Paul

    PS, you can try the MT1z with the Component input, i've heard it gives a great improvement over Svideo if you wish to dump the PC.
     
  8. Jenz

    Jenz
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Another thing to double check is that all Power Management in both the Operating System and Bios is disabled.

    Also disable all Autoplay settings on CD/DVD, and ensure that nothing else is running.

    I assume it happens when you're connected to a Monitor also not just the Projector?

    Matrox should be replaced with a Geforce 2 MX or Radeon.

    Regards Jenz.
     
  9. pc99

    pc99
    Active Member

    Joined:
    Feb 28, 2001
    Messages:
    255
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Milton Keynes, United Kingdom
    Ratings:
    +3
    Hi again all, I've been experimenting.

    I downloaded Cacheman (thanks Duncan) and also tweaked a few other settings.

    I now have virtually glitch free playback. It only glitches in complicated scenes with a lot of detail - which suggests that it is the graphics card not being up to the job. Before it used to glitch even on simple scenes.

    I think reducing the resolution to 800X600 helped quite a bit.

    Fulabeer, I found that WinDVD and PowerDVD gave awful pictures at this resolution with noticable jaggies (worse than my Pioneer 515 player). But the Matrox DVD player did a much better job.

    Anyway thanks to all who helped out. I just have to decide whether to splash out on a new graphics card, or upgrade my existing DVD player instead.

    Regards - PC99
     
  10. WSquared

    WSquared
    Active Member

    Joined:
    Jan 31, 2001
    Messages:
    215
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Bristol, UK
    Ratings:
    +3
    I would splash out on a new graphics card. Either the ATI or the GTS 2 PRO/Ultra. Nvidia is better if you want to play any games. Use WinDVD and DVD Genie. DVD Genie will enable a "hidden" Nvidia hardware support feature in WinDVD.

    I just ordered the Elsa Gladiac Ultra from Scan, £199 + VAT. Expensive I know, but I play a lot of games and already have the Revelator 3D glasses for them. Beautiful. Can't wait to get it.

    BTW, I also have the KT7A, with 1.2GHz Athlon running at 1.4GHz, & 256MB Cas2 Crucial memory running at 150Mhz, & Pioneer region-free/RCE DVD Rom drive.
     

Share This Page

Loading...