Planet Earth 2 Ultra HD Not Playing on Xbox One S

jules75

Member
Hi

I just received my copy of Planet Earth 2 on Ultra HD HDR Blu Ray from amazon.co.uk. However, I can't get either of the Ultra HD discs to play on my Xbox One S. The accompanying Blu Rays play, and my other Ultra HD Blu Rays play, but not Planet Earth 2. The Blu Ray player app either just sits at its blue loading screen, or it comes up with a disc error. I've tried a full cold boot of the Xbox but that doesn't work.

It would seem unlikely that both discs are faulty, and it's equally odd that all other discs, including other Ultra HD discs are working.

Anyone else got a problem?

TIA
 

Graham

Well-known Member
I put disc 1 of the UHD into my Xbox One S last night and it played fine. Have you updated to the latest firmware?
 

jules75

Member
I put disc 1 of the UHD into my Xbox One S last night and it played fine. Have you updated to the latest firmware?
First thing I checked. I'm on OS 10.0.14393.2152. Have also just tried removing the Blu Ray app, full reboot and re-installation. Still the same problem.

Could be faulty discs?
 

tkmin

Active Member
I have the same problem. Disc 1 won't plat at all, disc 2 plays after about 10 attempts. Both disc play absolutely fine on my Panasonic ub700 so it is deffo an Xbox issue.
 

jules75

Member
I have the same problem. Disc 1 won't plat at all, disc 2 plays after about 10 attempts. Both disc play absolutely fine on my Panasonic ub700 so it is deffo an Xbox issue.
Well, I'm glad to hear it's not just me then!! I even had Amazon send me out another copy but it was the same problem.

I've posted the same question on the Xbox Forums as well. But it will be useful to know I'm not the only one. If I find a solution I'll let you know.

Only problem is I don't have another Ultra HD Blu Ray Player!!!
 

thewoe2

Active Member
I had this issue too, i just had to keep ejecting and reinserting and it eventually worked, im going to get a standalone soon as the xbox one s is too temperamental
 

jules75

Member
Happy, but also unhappy to hear that I'm not the only one to have the problem. I really want to avoid another box under the TV!
 

jules75

Member
Xbox Support have suggested it might be a problem with the mastering of the disc and I should contact the studio for support! I'm not even entirely sure how I go about contacting BBC Earth for a problem like this...
 

mikemag

Distinguished Member
It's an odd suggestion considering you're talking about a brand new release, but on the Oppo 203 Owners thread some of the playback problems were solved by cleaning the discs and trying again.

There was a suggestion that a coating applied during the manufacturing process remained and stopped the discs being read by certain players.
 

jules75

Member
It's an odd suggestion considering you're talking about a brand new release, but on the Oppo 203 Owners thread some of the playback problems were solved by cleaning the discs and trying again.

There was a suggestion that a coating applied during the manufacturing process remained and stopped the discs being read by certain players.
Cheers Mike. The only cleaning I ever do would be a the removal of a finger print or a bit of dust. Removing a coating sounds a little more involved? How would you go about it?
 

mikemag

Distinguished Member
Nothing more aggressive than as if you were removing a fingerprint with a microfibre cloth. It probably won't work but it won't make things worse so I reckon it might be worth a punt :)
 

jules75

Member
Nothing more aggressive than as if you were removing a fingerprint with a microfibre cloth. It probably won't work but it won't make things worse so I reckon it might be worth a punt :)
Mike, I admit I was dubious about this tip, but as you say it's worth a punt. So I did. And it worked!!

Can't believe it. The discs never had any visible signs of dust or damage, but a wipe around with a nice clean, soft microfibre cloth seems to have done the trick. I've tried both discs twice, and chapter skipped through the entire series with no issues. I'll need to play through both discs to be sure, but it looks promising.

Oh, and the picture quality....it just shines on my Sony 4K HDR TV... everything I hoped it would be! Well worth the wait.

Thanks so much for the suggestion...you're a legend!
 

mikemag

Distinguished Member
Whew ! Glad it worked.

I don't have a 4k display myself but I thought about getting an XBox as a player whenever they update the firmware to allow Atmos audio.

The fact that I also might also be able to play my Xbox 360 Lego Star Wars Complete Saga has nothing to do with it :D
 

jules75

Member
Atmos support, I believe, is currently deployed to those Xbox users who are in the Insiders programme. This should mean it will be included in the next OS update which will hopefully come around the same time as the Creators Update for Windows 10. It will be time to buy my Atmos speakers soon!

Lego Star Wars - :thumbsup:
 

mikemag

Distinguished Member
Thanks for that, picked up a One S on Sunday so I'm looking forward to the update.
 

sedalbis

Well-known Member
Just a heads up - I couldn't get this to work properly on my Xbox One S. Disc 1 would only play in 1080p with no HDR and disc 2 wouldn't play at all. Other UHD Blu-rays and games would all play in 4K with HDR.

I solved the issue by going into the Xbox One S video settings and ticking 'Allow YCC 4:2:2' and now both discs play in 4K with HDR. No idea what this setting means but it did the trick!
 

totallyrads

Novice Member
Just a heads up - I couldn't get this to work properly on my Xbox One S. Disc 1 would only play in 1080p with no HDR and disc 2 wouldn't play at all. Other UHD Blu-rays and games would all play in 4K with HDR.

I solved the issue by going into the Xbox One S video settings and ticking 'Allow YCC 4:2:2' and now both discs play in 4K with HDR. No idea what this setting means but it did the trick!
Thank you so much for this. I was going crazy trying to figure out why 4K and HDR wouldn't work and this did the trick.
 

jules75

Member
I continue to have problems with this title. I thought they were resolved with the "cleaning" of the discs but I can only get it to play intermittently. I've also now tried enabling YCC 4:2:2 but continue to get the same issues. I even tried bypassing my AV receiver and using a direct HDMI connection to the TV. At a loss.
 

jules75

Member
Weird - works perfectly for me.
I did a factory reset of the Xbox a few weeks back and that has improved the situation. It works more often than not now, but still prone to the occasional load failure.

I have at least watched all six episodes. The picture blew me away. I watched the blu-ray and it looked "terrible" by comparison! lol
 

djdeejay

Active Member
I did a factory reset of the Xbox a few weeks back and that has improved the situation. It works more often than not now, but still prone to the occasional load failure.

I have at least watched all six episodes. The picture blew me away. I watched the blu-ray and it looked "terrible" by comparison! lol
Good to know, no problems for me yet touch wood - haven't watched much for it to be honest, but probably loaded it up 8 times without issues (only watched first 10 minutes testing out HDR)

I'm using the limited edition storm grey Xbox One S but the manufacturing date looks to be very early on (August 16) so must be in the first batch of S's.
 

JimboH

Well-known Member
Count me in - only tested quickly as watching it over the weekend but seemed to play fine on the Xbox :thumbsup:
 

Similar threads

The latest video from AVForums

LG CX 4K OLED TV Review: The best TV of 2020?

Trending threads

Latest News

TV licence fee now applies to over 75s from 1st Aug
  • By Andy Bassett
  • Published
New H.266 video codec promises 50 percent data saving
  • By Andy Bassett
  • Published
Toshiba launches UL20 4K HDR TVs from £299
  • By Andy Bassett
  • Published
LG GX soundbar launches in UK
  • By Andy Bassett
  • Published
Sky Q updates smart features and adds Disney Plus in HDR
  • By Andy Bassett
  • Published
Top Bottom