Pixels and signal

dwelly

Standard Member
Hi - I've had my Pan 37PX700 for a couple of months now. I'd love to say everything's gone really well but unfortunately cannot...

Apart from the clicks which most people seem to have, I've also, on a few occasions, had a "breaking up"/pixellated picture on Freeview, and more often than not no signal via Sky. The Freeview thing was really bad tonight and my Sky picture has been terrible ver the last few weeks - some days/nights it's OK for a while but most days it's far from OK cos there's no signal quality or strength showing. Of course the Sky thing might be a problem with my digibox or satellite dish but I wondered - has anyone else had this pixel or signal problem with the PX700?
 

Kev12

Well-known Member
Hi - I've had my Pan 37PX700 for a couple of months now. I'd love to say everything's gone really well but unfortunately cannot...

Apart from the clicks which most people seem to have, I've also, on a few occasions, had a "breaking up"/pixellated picture on Freeview, and more often than not no signal via Sky. The Freeview thing was really bad tonight and my Sky picture has been terrible ver the last few weeks - some days/nights it's OK for a while but most days it's far from OK cos there's no signal quality or strength showing. Of course the Sky thing might be a problem with my digibox or satellite dish but I wondered - has anyone else had this pixel or signal problem with the PX700?

It sounds to me that you need to check the alignment of the dish and aeriel.
 

The latest video from AVForums

LG G1 OLED Evo TV and SVS SB-1000 Pro subwoofer reviews, Samsung OLED rumours and more...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom