pioneer VSX-C300 problem

Discussion in 'AV Receivers & Amplifiers' started by shaunthedude, May 13, 2002.

Tags:
  1. shaunthedude

    shaunthedude
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have the above amp and the centre speaker is now not working. It is hissing but no sound is coming out of it. I tried another speaker with new wire but that is the same. I checked the settings etc but when i come to centre speaker the dispaly on the amp says "centre- NON" Any ideas as to how to fix this.

    cheers all

    shaun
     
  2. Electric Mayhem

    Electric Mayhem
    Distinguished Member

    Joined:
    Mar 16, 2001
    Messages:
    10,620
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    United Kingdom
    Ratings:
    +2,221
    Hi

    If it wont let you select a centre speaker in the setup menu then it looks like you´ll have to take it to a shop and get it looked at.

    Could be a short somewhere?? or the centre channel amp might have blown??

    Best get it to a service centre.
     
  3. shaunthedude

    shaunthedude
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    cheers matey.Just been doodling on with it and it now works. i have no idea what I did but its ok now.

    cheers anyway

    shaun
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice