• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Pioneer SC LX-85 No Sound - Help!

Jaruzel

Standard Member
Hi Guys,

I've got a 2 year old Pioneer SC-LX85 that now outputs no sound whatsover - even via the speaker levels test tones, or the MCACC setup - it's totally silent. A couple of times over the past few months it's had UE22 flashing on the display but a full power off/on typically cleared it. It's not showing the UE22 currently, but I still have no sound.

I've tried the following:

1. Firmware update over the internet - fails at 20% with 'Update Error 1'
2. Firmware update over USB - fails at 20% with 'Update Error 1'
3. Factory Reset via pressing Enter during power on.
4. Leaving it powered down and disconnected from the mains for 5 mins.
5. Checking speaker cables for shorts or problems - nothing wrong.

I can hear the amp circuit clicking on/off when the amp modes are cycled, but it's still totally mute :(

Any ideas? Have I exhausted all diagnostics here?

If I have to send it off for repair, can someone recommend a good authorised Pioneer repair centre in the UK ?

Many thanks!

-Matt
 
Last edited:

Averissimo

Novice Member
Hi Matt,

I was guessing to know how did you solve the problem..
I actually just had the same exactly problem that you described :/
 

Jaruzel

Standard Member
Hi there,

Your post just hit my email inbox, so before I forget, I'll reply right now.

Turned out it was broken; I ended up sending it off for repair. It came back with almost entirely new insides. Luckily, even though it was 1 month over the warranty period, Pioneer agreed to pay for the repair.

It's been fine since. Which is annoying as I'd quite like an Atmos enabled amp now :)

I think the takeaway is, if you repeatedly get UE22 and you can't clear it. Something is busted.
 

Averissimo

Novice Member
i also had on my amp display showing UE22.. Funny case i didnt even try to update it.
after checking for more info i decided to try to update the firmware since the error was from a suppose update..
No need to say that all the attempts failed with around 15-20% progress.
I have tried to reboot the system.. reset the fabric settings and the result was the same..
i keep not having sound..
I have just called the Pioneer center support from NL and it was told me that with reset settings should resolve the issue.. but i have tried that before with no results.
I guess i will have to try my luck sending the amp there and spend some money on it :/
 

The latest video from AVForums

SVS Prime Wireless Pro Powered Speakers - Review Coming Soon
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom