Pioneer plasma speakers can i use these

Discussion in 'Home Cinema Buying & Building' started by Largepat, Jan 1, 2012.

  1. Largepat

    Largepat
    Standard Member

    Joined:
    Jan 10, 2009
    Messages:
    81
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Please help,
    I have a 5.1 surround system comprising of 43in Pioneer Plasma
    Onkyo Tx-Nr 1009
    4x Mordaunt Mezzo 6 speakers = 2 front and 2 rear
    I have a Mordaunt Mezzo 5 centre speaker and mezzo 9 subwoofer

    I was wondering if I could change this 5.1 setup to a 7.1 surround by
    connecting the pioneer mounted speakers as 2 high front speakers as
    these speakers at the moment are not being used.
    The Pioneer speakers are PDP s37 side mounted.
    The speakers will be high enough as they are about 14in from
    the ceiling.
    BUT ARE THEY GOOD ENOUGH TO USE WITH THIS SETUP

    I WELCOME ALL ADVICE ON THIS MATTER. THANKS.
     
  2. davepuma

    davepuma
    Distinguished Member

    Joined:
    Jun 24, 2004
    Messages:
    17,520
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +3,505
    The impedance rating looks okay so why don't you just try them?
     
  3. Largepat

    Largepat
    Standard Member

    Joined:
    Jan 10, 2009
    Messages:
    81
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Thanks Dave will do, just didn,t want to go buying Plugs and cable
    if the speakers weren,t up to it
     
  4. Largepat

    Largepat
    Standard Member

    Joined:
    Jan 10, 2009
    Messages:
    81
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Need help again, connected the 2 high speakers to my onkyo, plugged in the microphone thingy
    a full room calibration was asked to turn my sub up to 75db at the start of calibration
    All speakers were picked up including my 2 front high.
    Calibration finished, put on toy story three and found that the onkyo had turned off the subwoofer,
    went into settings and turned it back on.
    PROBLEM IS,I cant hear anything coming from my 2 front high speakers.
    Would have thought I would have heard the the 2 front high especially in toy story 3
    Cant hear them in any mode,
    Anyone got any ideas to my problem, Thanks.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice