Pioneer LX55

Discussion in 'Blu-ray & DVD Players & Recorders' started by bazkav, Jul 15, 2015.

  1. bazkav

    bazkav
    Active Member

    Joined:
    Jan 6, 2003
    Messages:
    215
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Leeds
    Ratings:
    +31
    The front led display on my pioneer BPD LX55 no longer works, has anyone else had this fault.
    The player is about 2.5 years old so out of its Sevenoaks warranty period. It still plays discs ok but I find it a limitless annoying on a player that's supposed to be a step above budget players.
    Would it be an easy repair or would it be better to sell it and buy something a little newer!
    Thanks in advance for any advice.
     
  2. MrR

    MrR
    Active Member

    Joined:
    Jul 16, 2005
    Messages:
    88
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    North of Cardiff
    Ratings:
    +7
    I've recently had the exact same problem on the Pioneer BDP-450 it's about 15 months old. It plays great but the display is totally blank. I took it back to Richersounds for them to send it back to Pioneer. I had a call back from RS today and Pioneer have said its not repairable!

    I'm not impressed with Pioneer's reply. It's still being available on the Pioneer website so why can they replace the part or the machine. RS are going to give me a credit note for the item as it was still within Pioneer's 2year warranty on audio components. I may look at the the Sony BDPS7200 or the Pioneer LX58 and pay the difference, but at an extra 300+ quid it's a bit off putting.
     
  3. bazkav

    bazkav
    Active Member

    Joined:
    Jan 6, 2003
    Messages:
    215
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Leeds
    Ratings:
    +31
    Yes as much as I like pioneer products they do seem to be a bit prone to faults. Before I got my SCLX57 amp about15 months ago I had the LX55 I sold it to my son in law for a nominal sum he's only had it for about a year and now it's got the UE22 fault which makes it inoperable, I have done a couple of full resets which work for a short time before the amp shuts down again.
    When I rang pioneer support there wasn't a lot of support to be had, he couldn't even nail down the exact fault of a UE22 just advised me to take it to a pioneer repair centre £40 to check before any price for work needed.
    I informed the phone advisor of my disappointment at a product costing £1000 lasting less than 3 years. He explained how much of a complex piece of kit it was, I countered that I had a car equally as complex which bounced along the highways of leeds yet kept working.whilst the av amp which just sits solidly upon my heavy duty support moving nowhere breaks down.
     

Share This Page

Loading...