Pioneer DV575 playing a green picture thru LCD projector- Help?

Discussion in 'Blu-ray & DVD Players & Recorders' started by maisbrough, Nov 27, 2004.

  1. maisbrough

    maisbrough
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Made the mistake of allowing my wife to play her Sex and the City DVDs on our DVD player and since then, the picture is only displaying the image in green... The Pioneer 575 is connected to a Epson LCD TW200 projector using the component cables. Not sure if this matters. The projector appears to be fine because the Xbox is playing with balanced colours on it.

    Any ideas how to rectify? I've tried the adjusting the DVD and projector menu settings for gamma, colour, contrast etc but no avail.

    Cheers.
     
  2. nwgarratt

    nwgarratt
    Distinguished Member

    Joined:
    May 5, 2002
    Messages:
    26,437
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +2,871
    It sounds like one of the component cabled has got loose either at the projector or the player end.
     
  3. maisbrough

    maisbrough
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks for the suggestion. I have checked the component cables and they are all connected properly but for some reason the picture is showing only green colour.

    I changed then DVD player and there was no difference. The Xbox is playing through a S-Video connection, so that explains why it is ok. Could it be the projector settings?

    Appreciate any other ideas..

    Thanks.
     
  4. Ged

    Ged
    Active Member

    Joined:
    Apr 29, 2002
    Messages:
    925
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Ratings:
    +17
    It maybe due to a setting within the Epson, I have a plasma which has a variable setting, I think it is when selecting the RGB signal input. It gives a choice of two, one of which makes the screen green, the setting I think is either Component or RGB, try using Component.
     

Share This Page

Loading...