• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Pioneer 8G Owners Thread - Part 3

Curly99

Distinguished Member

Dave H

Prominent Member
My 508xd is still going strong :D
 

Pfeffernuss

Established Member
My 508xd is still going strong :D

Same here! Happy with it on a daily basis. Still haven't found any need to "upgrade" it. When going to friends and seeing their shiny new FullHD "LED" :)boring:) thingies I'm initially impressed (especially during daylight) but when watching a movie later on that positive feeling drops rapidly.
Coming home and switching on the trusty old HD-Ready beast all is well. Well, not all, but close :D
 

belongamick

Established Member
I've had my 4280xd for 2-3 years now and have been very pleased with it apart from the nagging feeling I'm not seeing all I should be, as its native resolution is only 1024 by 768.

This fact nearly stopped me from buying it in the first place but after research concluded I was sitting far enough from my TV to probably not notice any less pictuire detail when compared with a true 1080p panel.

I've never had the oportunity to compare it with a truehd set or spend any length of time watching one - what do you recon guys - am I missing out or am I just looking for a reason to upgrade? :)
 

Snevabud

Standard Member
I love the TV, Im now thinking its just the digital reception im getting because some channels are much better than others, I would have thought if it was the TV all the channels would be the same poor quality but some channels are near perfect especially since I changed some settings.
 

noslarc

Standard Member
I just bought a second hand 4280xd and absolutely love it. The picture is great and initially it was dead silent. However, after wall mounting it something odd happened - it started buzzing quite loudly. I've read about buzzing Kuro's and I've read that if you damage the screen that could cause buzzing. I'm now wondering if I could have cracked the screen when removing the stand and attaching the wall mount or if this is some other type of buzzing.

I tried to search for Kuro and buzzing but there's just too many posts about this. Any ideas as to the cause and potential fixes for the buzzing? My wife doesn't hear it so maybe it's just one of those things that you start obsessing about once you notice...

-Jonas-
 

Snevabud

Standard Member
Mine has buzzed since i got it but I was told because I mounted it in a corner its the sound bouncing off the walls as you can only hear it if you sit straight on with the TV? Sometimes its louder than others but doesnt really bother me anymore. I also had poor speaker quality at one point like the speakers were damaged but re-did the speaker wires into the TV and it has been fine ever since.
 

belongamick

Established Member
Mine has always buzzed to some extent, but its not audible at normal TV volume levels. Adjusting the Drive Mode number I believe as the side effect of changig the buzzing noise.

Maybe because your tv is now on the wall it has exaggerated the volume of the buzzing that was always there?
 

ozzzy189

Distinguished Member
belongamick said:
I've had my 4280xd for 2-3 years now and have been very pleased with it apart from the nagging feeling I'm not seeing all I should be, as its native resolution is only 1024 by 768.

This fact nearly stopped me from buying it in the first place but after research concluded I was sitting far enough from my TV to probably not notice any less pictuire detail when compared with a true 1080p panel.

I've never had the oportunity to compare it with a truehd set or spend any length of time watching one - what do you recon guys - am I missing out or am I just looking for a reason to upgrade? :)

Keep it mate, negligable difference, unless your viewing distance is stupidly close, stunning tv. Still. Resolution in not massively important at that size, even 50 inch, just enjoy it.
 

belongamick

Established Member
Keep it mate, negligable difference, unless your viewing distance is stupidly close, stunning tv. Still. Resolution in not massively important at that size, even 50 inch, just enjoy it.

Cool, thanks for the reassurance. Yeah, have to admit the picture quality still makes me think wow every now and then - have been watching The Pacific recently and some of the scenes look incredible!
 

bighfishing

Prominent Member
I just bought a second hand 4280xd and absolutely love it. The picture is great and initially it was dead silent. However, after wall mounting it something odd happened - it started buzzing quite loudly. I've read about buzzing Kuro's and I've read that if you damage the screen that could cause buzzing. I'm now wondering if I could have cracked the screen when removing the stand and attaching the wall mount or if this is some other type of buzzing.

I tried to search for Kuro and buzzing but there's just too many posts about this. Any ideas as to the cause and potential fixes for the buzzing? My wife doesn't hear it so maybe it's just one of those things that you start obsessing about once you notice...

-Jonas-

since wall mounting it are you sat dead centre by any chance, if you are sat dead centre to a 4280xd you will notice the buzzing more than if you are sat just off centre. i was told this before i bought mine and its true, something to do with a cone or something like that i was told. i hate any noises that shouldn't be there like buzzing or fan noise on any product and always return them if they annoy me but i must admit the slight buzzing on my 4280xd doesn't annoy me at all and i sit dead centre to it. the picture quality is so good you just forget about anything else.
 

Ocellia

Standard Member
I have one of the last 8G (50XD) , bought from Costco in Dec 09 at a bargain price.
Have a problem.
In March, on Switch-on (I keep it on 'Standby') it would revert to 'Set-up' EACH TIME!.
So have to run through the tuning procedure every day.
Did this each day/time, for about 10 days. Costco were about to arrange a fix....when it went back to 'normal'.
But now (May 5) it has started to do the same again.
Costco have arranged to get it looked at by local repairers.
I'm not too impressed with their attitude so far.(The repairers,; Costco are good!)
"We don't usually do these....if we can't get parts, you'll have to get a refund from Costco and get something else...." etc!
NOT what I want to hear. AS other owners will know, we bought these because they are the BEST!. Not some fashion item to be replaced by this years fancy!
Anyway.
Has anyone else come across the same 'Re-tuning' situation?
As it 'fixed itself' for 6 weeks, I'm guessing it could just be a connection problem (chip leg intermittency?).
It seems that it loses all channels overnight on memory, though the final readout does say 'xxx duplicate channels replaced' at the end.
I'm hoping that the repairers will do fine, despite my anxiety!
All input gratefully received!
 

steve_1976

Established Member
Hi, I have not had the problem but I have not used the freeview tuner since I do not have a roof top ariel. However, if the repairers tried to take it away so I could get something else I would tell them where to go!!! :nono:

If the worst comes to the worst and they can not repair it I would try to get a partial refund, keep the TV and use the refund to by a top of the range external freeview box??

That way you'll still have great tv. If you negiotate enough you could also get a harmony one remote to you do not have to use two remotes of the same functionality you currently have.

Good luck :smashin:
 

Ocellia

Standard Member
Thanks steve.
Funnily enough, it 'fixed itself' again today!. But......
I used to use a Freeview box with my CRT T.V. (Obviously!)
The problem would still arise as the 'Set-up' page appears when I turn it on, each time!
With FOUR remotes, I like your 'Single' concept. (T.V./Blu-ray/Amp,/Topfield!)
Costco are quite good on refunds, I hear!
But I just want a quiet life, and a Kuro!
 

steve_1976

Established Member
Thanks steve.
Funnily enough, it 'fixed itself' again today!. But......
I used to use a Freeview box with my CRT T.V. (Obviously!)
The problem would still arise as the 'Set-up' page appears when I turn it on, each time!
With FOUR remotes, I like your 'Single' concept. (T.V./Blu-ray/Amp,/Topfield!)
Costco are quite good on refunds, I hear!
But I just want a quiet life, and a Kuro!

Hmmh ok I miss understood. That must be annoying... I am guessing you've tried the turning it off at the mains for a while? I dread anything going wrong with mine.. I can't think what they'd offer me as a replacement... I hear the latest panasonics are getting close to kuro blacks but the ones that do are probably the ones JL have where they used to have the Kuro's... and cost about 3.5k!!! I thought the Kuro's were expensive!!:laugh:

As for the remotes.. I do recommend them. Takes a little while to set up precisely as you want but once done.. all my other remotes live in draw and I just from watching tv, to listening to music and to watching a movie with on button and the amp switched to the preferred sound mode for each etc. Only thing I wish is the kuro could be flipped between different modes with one command.. I prefer different settings for tv and BR.
 

Adge13

Established Member
I am just wondering if any one gets the same results as me?
I have a 508XD for a few years now and have noticed very faint horizontal black lines on the picture in drive mode 2 . These lines can be seen noticably on whites and have been there from the start. I use drive mode 2 for watching sport from Virgins V+ box as drive mode 1 gives on juddery picture.
The V+ box is set to 1080I and even if I change it to 720p the lines still can be seen.
I have found that if I turn on Text optimisation the faint lines seem to be improved but not sure?
I have set all settings to ******** settings apart from the above.
Can anybody help me?
 
Last edited:

steve_1976

Established Member
I've just tired changing from drive mode 1 to 2. I don't quite see that but something a bit worse on drive mode 2 and whites. I also have virgin v+. The obvious question would be.. why are you wanting to use a drive mode where you see that and described as for scrolling text to watch sports? I am probably missing something here.

Btw, I've now brought all the home cinema equipment I can. So considering getting mine tv calibrated. Has anyone done this? Is it worth the expense? Can anyone recommend someone in the hertfordshire region?
 

Adge13

Established Member
I only put it on drive mode 2 when watching football. On drive mode 1 the players jugger alot. I know I am really fussy and the average person would probably not see it. Just wondered if anyone else can see it?
I havev't tried it on Blu Ray yet.
 

Kev12

Prominent Member
I've just tired changing from drive mode 1 to 2. I don't quite see that but something a bit worse on drive mode 2 and whites. I also have virgin v+. The obvious question would be.. why are you wanting to use a drive mode where you see that and described as for scrolling text to watch sports? I am probably missing something here.

Btw, I've now brought all the home cinema equipment I can. So considering getting mine tv calibrated. Has anyone done this? Is it worth the expense? Can anyone recommend someone in the hertfordshire region?

It would be well worth getting it calibrated.
Gordon Fraser did my 428 and I can recommend him, but all the calibrators will travel.
 

steve_1976

Established Member
I only put it on drive mode 2 when watching football. On drive mode 1 the players jugger alot. I know I am really fussy and the average person would probably not see it. Just wondered if anyone else can see it?
I havev't tried it on Blu Ray yet.

I'll give it a go next time I watch a footy match. Since my team got knocked out the playoffs on Monday... it might be a while :rolleyes:
 

steve_1976

Established Member
It would be well worth getting it calibrated.
Gordon Fraser did my 428 and I can recommend him, but all the calibrators will travel.


Thanks Kev.. how do I go about finding Gordon or any other calibrator? This sounds like an amatuer question I know :blush:
 

Bumtious

Banned
steve_1976 said:
Thanks Kev.. how do I go about finding Gordon or any other calibrator? This sounds like an amatuer question I know :blush:

Send a private message to any of them or look on the ISF website for UK dealers.
 

Pedantic

Standard Member
Damn! After 3 good years with my 4280XD, it looks like it's gone and died on me. I'm now presented with 2 flashing red lights, then a pause, then 2 flashing red lights, and so on and so on. I have followed the manual, turned off and wait a couple of minutes to no avail. And done the same unplugging the set from the mains, and waiting a couple of minutes again. Nothing doing I'm afraid. Just getting the same recurring red light sequence. The real bummer is, I bought the set from Empiredirect, who felt the full force of the recession, and went into administration. Does anybody know what the problem could be? And what my next step could be? It's well past it's warranty, so it looks like I'm goosed. :rolleyes:

Thanks for any advice.
 

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom