1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pioneer 433 power problem

Discussion in 'Plasma TVs' started by chmaiden, Aug 20, 2005.

  1. chmaiden

    chmaiden
    Standard Member

    Joined:
    Nov 10, 2003
    Messages:
    112
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Ratings:
    +0
    guys...just switched on the pioneer and there was a big old bang, bit of a flash on the screen and the circuit tripped in the house. turned it all off and left it for a bit, but...

    got power to the media box, but the screen is blank with the standby light flashing....

    any ideas? big/expensive repair or ?

    tia

    c
     
  2. ikon66

    ikon66
    Active Member

    Joined:
    Mar 22, 2005
    Messages:
    397
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Tyne & Wear
    Ratings:
    +7
    power supply I would guess :confused:
     
  3. Skeets_de

    Skeets_de
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Classic symptoms of the High Voltage Power Supply blowing. :(
     
  4. chmaiden

    chmaiden
    Standard Member

    Joined:
    Nov 10, 2003
    Messages:
    112
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Ratings:
    +0
    how much is that going to cost to get repaired roughly?! the set is about 2 years old...any redress from pioneer?
     
  5. Skeets_de

    Skeets_de
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    EU Warranty is 2 years in Germany and since the UK is in the EU...sometimes.

    As to repair costs it depends on whether it was just a capacitor or diode or the whole P/S or if it took something else with it. The bang indicates a filter capacitor short circuiting which drew heavy current resulting in the breaker popping. :rolleyes:
     

Share This Page

Loading...