1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pio 503MXE image problems

Discussion in 'Plasma TVs' started by sticker, Nov 19, 2003.

  1. sticker

    sticker
    Standard Member

    Joined:
    Jan 14, 2003
    Messages:
    1,152
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    36
    Location:
    Sydney, Australia
    Ratings:
    +0
    Hi,
    I’ve had my Pioneer PDP503MXE now for about 10 weeks and I’m having considerable problems with the image quality. The biggest problems revolve around SKY, which at times has truly appalling picture quality, but in particular sport.

    I’m running from an Amstrad digi box (DRX100) to a JS RGB to YUV converter, this is then feeding into an Arcam AV8. From the AV8 the component output is feeding into a Lumagen Vision which outputs via VGA to the Pio. The cables I'm using are Better Cables on all apart from the SCART which is a Lectopaks.

    The problems that I have with SKY are as follows;
    1) Moving images blurred & fuzzy, in particular on fast moving images and fast pans there is considerable ghosting and colour bleed.
    2) Football is almost unwatchable, looks like a low resolution dial up Internet feed
    3) Stuttered images
    4) Text blocky with jagged edges
    5) Ticker tape very jerky
    6) Text blurred at times takes a few seconds to become clear
    7) No depth of field, near distant images are very blurred
    8) Images are pixelated and mis-coloured
    9) Skin does not look like skin
    10) Grass does not look grass
    11)Jagged edges on objects

    The readings on the SKY set-up box are Quality 60%, Strength 75%, Medium contrast, and RGB output.

    Any assistance would be much appreciated.

    Regards
    John
     
  2. philipb

    philipb
    Active Member

    Joined:
    Mar 6, 2002
    Messages:
    1,989
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    63
    Location:
    Swindon
    Ratings:
    +132
    I have the 433, so not identical but close enough i hope to be of some help. You should get much better results than you are - the 503 MXE is a superb display.

    What are the settings you have for contrast etc? The factory defaults are not optimum.

    It almost sounds like the feed is being processed to death. I doubt that the Sky input is totally to blame. Take the component from the JS converter straight to the component in on the 503. See what effect that has. This will probably be a process of elimination, so let us know how you get on and we can go from there.

    Have you spoken to the supplier?
     
  3. nealgs

    nealgs
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    again have the 433, but setup wise have dvd->sky (amstrad DRX100 IIRC)->JSTech RGB2YUV->Amp->Panel.

    Picture is very good, does depend on channel though, some better than others by far. Watched some of the football lastnite and whilst picture wasn't perfect (mainly distant shots of players were slightly fuzzy :) ) but i'd say nowhere near as bad as what Sticker is describing, and not much different to our old Panny 32PF10 CRT

    I'd suggest trying as philipb says, start simple with just skybox connected via rgb2yuv->amp->plasma. matter of a process of elimination i think.

    Cables are cheapo Component from Maplin for RGB2YUV->Amp, and some much better ones for amp->panel (can't remember name now - doh!)


    regards
    Gary
     
  4. alwyn

    alwyn
    Active Member

    Joined:
    Dec 10, 2002
    Messages:
    562
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    west country
    Ratings:
    +13
    I have just sold my pdp503mxe and the PQ was super.I think your problem could be your line doubler
     
  5. Gordon @ Convergent AV

    Gordon @ Convergent AV
    Distinguished Member AVForums Sponsor

    Joined:
    Jul 13, 2000
    Messages:
    14,011
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    Living in Surrey, covering UK!
    Ratings:
    +2,808
    The judder is likely to be caused by the processing but the detail disappearing in motion is most likely mpeg artifacts.

    Send me an email with the output resolutions and configuration you have Vision set at.

    Gordon
    convergentav@btinternet.com
     
  6. sticker

    sticker
    Standard Member

    Joined:
    Jan 14, 2003
    Messages:
    1,152
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    36
    Location:
    Sydney, Australia
    Ratings:
    +0
    Hi Guys,
    Thanks for the replies.

    Pio settings are as follows;

    Contrast is set at -6
    Brightness -4
    Colour -16
    Tint - 3
    Sharpness -7
    Colour temp = middle
    Digital NR = middle
    High contrast = off
    Clamp position = auto
    Video signal = RGB
    Power control = mode1

    I have used Avia and The Ultimate DVD to try to set up the panel.

    I've tried a straight component out from the AV8 into the Pio and there was a difference, perhaps a slightly worst picture and worst artifacting. Unfortunately there was no football on at the time to try that aspect

    Gordon, an e-mail is on its way.

    Thanks to you all for your input, its much appreciated.

    Regards
    John
     
  7. waynepoos

    waynepoos
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    i bought a second hand pio pdp503mxe and it has a pink rash across the screen about 7 inches down from top of screen can anyone help me cure it please.
     

Share This Page

Loading...