Philips PUS6554. Cast icon in YouTube.com video player MISSING

Prsnr

Novice Member
Hello,

TL;DR No cast icon(in video player on YouTube.com via Chrome) when using YouTube app on Smart TV, while the cast icon appears when using the YouTube app on PS4. Both apps are the same version

I bought a Smart TV Philips 43PUS6554/12 in February 2020.
I was able to cast videos from YouTube.com through Chrome browser to my TV until November 2020. One day the cast icon mysteriously disappeared and never appeared again.

I started so many threads in numerous forums, asking for advice but nobody was able to help me.
I sent numerous feedbacks from the TV's YouTube app itself and from my laptop - no result.
I posted a new question in the Chrome Support forums and a Gold Product Expert sent me to Chromium bugs website so I opened a new issue there, because I thought that it must be Chrome that is bugged. The technicians there asked me to send them a feedback(logs) using Chrome Canary. I did it but then they replied:
I took a look at the logs and am not seeing any errors related to DIAL app availability, so for some reason we're not getting a message from the TV saying it's compatible with YouTube.

I don't think this is actionable for us right now unless we can get a local repro. It might be an issue on the Chrome side or the TV side but we can't tell.

Things I've tried:
  • To reset the YouTube app on TV - no cast icon.
  • To delete it and re-add it - no cast icon.
  • Using Chrome incognito mode - no cast icon.
  • Using Chrome Canary - no cast icon.
  • Restarting laptop/browser/router - no cast icon
  • Updating Chrome - no cast icon
The app was recently updated from web_20201208_00_RC04 to web_20210124_00_RC00 but again - no cast icon.

I remembered that my PlayStation 4 Pro has the YouTube app. So I decided to test it and to my surprise the cast icon immediately showed up on YouTube.com (via Chrome). I check the YT app version on the PS4 and it's the same as on the TV. I find this very strange. I'm confused.

Is it a TV problem or is it an app problem?

I checked again the requirements for casting YouTube videos and couldn't see if my TV was removed from the compatible devices. All that is needed is Smart TV with the YouTube app and the same network. I was using this function for 9 months without even thinking about requirements.
I've spoken with Philips and even asked them to contact YouTube since they have some connection(I guess). They told me that they don't think it's a TV problem.

I'm lost.

Here are a few screenshots

This screenshot is from Chrome
FKuwnxB.jpg


This screenshot is from Chrome
ar3IT5B.jpg


ip3SD6c.png

The YouTube app version in the screenshots is the old one because I'm lazy to make new photos.
X8TzsOk.png

The YouTube app version in the screenshots is the old one because I'm lazy to make new photos.

When using Chrome Canary it's saying "Available for specific video sites"

This screenshot is from Chrome Canary



Chrome was recently updated and it also shows the same "Available for specific video sites"
 

l00pu5

Active Member
Seeing the same here in conjunction with my 55OLED754 (same platform / SW branch) and Chrome 88 @ ChromeOS.

Very weird, 'cause I could also bet that it was working at some point the past. Not using this function heavily, though...
 

Prsnr

Novice Member
Seeing the same here in conjunction with my 55OLED754 (same platform / SW branch) and Chrome 88 @ ChromeOS.

Very weird, 'cause I could also bet that it was working at some point the past. Not using this function heavily, though...
I've been using this function a lot and when Philips replied to me that the problem is not in the TV and that Chrome does not allow that - I went mad.
Thanks for the comment. I will include it in my next email to Philips.
Something is terribly wrong....

P.S. Could you please write down the software version of your TV?
Mine is TPM196E_091.003.255.001
 

l00pu5

Active Member
I've been using this function a lot and when Philips replied to me that the problem is not in the TV and that Chrome does not allow that - I went mad.
Thanks for the comment. I will include it in my next email to Philips.
Something is terribly wrong....

P.S. Could you please write down the software version of your TV?
Mine is TPM196E_091.003.255.001
Same. Will try to fall back to an earlier release to see if the behavior changes (which would be extremely weird...)
 

Prsnr

Novice Member
Same. Will try to fall back to an earlier release to see if the behavior changes (which would be extremely weird...)

Yeah. Today I saw that your TV and mine use the same software updates.
I've already asked Phillips to send me PKG files (Upgrade loader) for the following updates.
TPM196E_091.003.210.001 acts the same - no cast icon.
Do you have the upgrade files?
1611943434274.png
 
Last edited:

l00pu5

Active Member
Hopefully, I still have this version around... will need to find it back and upload it once I found it. Will let you know.
 

Prsnr

Novice Member
Hopefully, I still have this version around... will need to find it back and upload it once I found it. Will let you know.

The file must be called upgrade_loader.pkg
I think "Autorun.upg" is only for updating, while the pkg file is used to downgrade.

Edit: Now I read in this forum that downgrade can be done with Autorun.upg file
 
Last edited:

Prsnr

Novice Member
@l00pu5
I have an update!
I spoke with a 50PUS7805 owner and he said that he is experiencing the same problem. He spoke with Philips Portugal and they told him that they are aware of the problem and are working on it and hope to fix it in a future update.
 

Prsnr

Novice Member
Actually Philips Portugal were thinking that the problem is connected to Miracast, but that's not the case... So this is still mystery

UP
 

Prsnr

Novice Member
I fixed the problem by downgrading the software to TPM196E_091.003.166.001.
I got it from Toengel's website.
 

The latest video from AVForums

Podcast: Sony A90J Thoughts, madVR Processor & Sonus faber Lumina II Reviews + Movie & TV roundup
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom