1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Philips PixelPlus Plasma FD9954 problem

Discussion in 'Plasma TVs' started by avfaamar, Jul 30, 2003.

  1. avfaamar

    avfaamar
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Got this new model July 1st, noticed a horizontal strip of greenish yellow lit pixels on the top of screen....and called Philips:
    First tech says probably the Ebox FTR9965 problem with reception and exchanged a new one for me a couple of days later.

    Same problem.

    Second tech came... showed him Contrast setting at 60, and Brightness at 52 - voila the greenish-yellow lit pixels on top and ALL OVER THE PANEL. Lower the brightness to 48... and the screen is dark and none of the greenish-yellow pixels. SO...he says its the panel problem and exchanged a new panel for me a couple of days later.

    Same problem.

    Went to the showrooms and TV stores to look at the same Pixelplus models. ALL 32 inch and 42 inch Pixelplus Plasmas have the SAME PROBLEM. Contrast 60, Brightness 51-52... and setting factory settings "natural", "rich", "soft" shows the greenish-yellow lit horizontal strip at the top.

    Given that I am a Plasma noobie, I am sure this isn't normal - the techs even said that.... So now I am waiting for the Quality Assurance Manager to give me an official response.

    Please check this carefully before you buy, seems like a serious problem and I am stuck... what should I do if they say this is normal??? :rolleyes: :mad:
     
  2. mikeq

    mikeq
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    tell them it is not normal and not acceptable, get a full refund.
     
  3. jmack

    jmack
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    maybe philips have turned the screens upside down;) . there was a line at the bottom of mine and other problems.

    i returned 2 models for same reasons about a year ago

    9952 and the 9964 model no.s

    get a exchange or refund
     
  4. pixie

    pixie
    Novice Member

    Joined:
    Aug 30, 2002
    Messages:
    41
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Bristol
    Ratings:
    +2
    Hi avfaamar,

    Sorry to hear that you've got a problem with your plasma.

    I too have a Phillips plasma (32" 9964). I bought this in August last year.

    I've just tried to replicate the problem with yours, with the settings you've suggested (contrast 60, brightness 52), and I can't get mine to display the greenish-yellow lit horizontal strip at the top (or anywhere else on the screen). The picture is normal, and without any problems.

    Perhaps there could be a problem with the newer model? Sounds like you need to get it swapped or get a refund for it.

    Sorry I can't be of more help,
    Pixie
     
  5. avfaamar

    avfaamar
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Pixie, thanks for checking. I tried out the old Philips model (the same exact looks without the new Pixelplus) at the retail store as well, and it is fine like you said - and it won the EISA award last year too.

    BUT...the new Pixelplus plasma model is screwed...

    I have to see how this goes, thanks folks...:(
     

Share This Page

Loading...