Philips/Pace HDT 8520 HD-PVR Master thread inc. Bug and Issues List [Part One]

Status
Not open for further replies.
When I switch box on I get searching for update message but no update found, tried pluggin in usb with firmware and force flashing but no luck, just searching for update message, any ideas?
 

ninjafeel1970

Active Member
I just taken mine back to currys, i cant put up with missing the programmes due to it not recording and all the other faults. I now have the new humax and so far its fantastic :smashin:. The epg is so much better too :lesson:
 

willp2003

Active Member
Odd. Just looked at this thread for the first time in weeks, read about the new firmware.
So turned on my Philips now to see what firmware I have and didn't even get to a menu - it was prompting an OTA update.

But you chaps have had it for a month already?

It's been on the philips website since late October.

Can anyone tell me how to fully disable the parental control feature on this unit? I keep getting recordings with the mother and child icon next to them, despite the parentalcontrol being off.

I'd try giving it a full reset, that should get rid of all your settings.
 

terryd1

Standard Member
Since updating to 5.15 everything seems to have slowed down. If I navigate to the recorded programs page, it appears but is empty and it's 2 or 3 seconds before the page is populated with names if I pick a program to play is seems to take ages to start. All sorts of strange things are happening like not being able to delete a program so it's a case of pulling the plug to reboot. the ver. 4.22 seems to have been quite a stable software so it's a pity that they seemed to have now taken a backward step with this ver. (I wonder if I can revert to ver 4.22)
 

E Shaw

Novice Member
When I switch box on I get searching for update message but no update found, tried pluggin in usb with firmware and force flashing but no luck, just searching for update message, any ideas?

Only thing I can suggest is to ensure the flash drive is in Fat32 format before extracting and copying the update to the drive :smashin:


Since updating to 5.15 everything seems to have slowed down. If I navigate to the recorded programs page, it appears but is empty and it's 2 or 3 seconds before the page is populated with names if I pick a program to play is seems to take ages to start. All sorts of strange things are happening like not being able to delete a program so it's a case of pulling the plug to reboot. the ver. 4.22 seems to have been quite a stable software so it's a pity that they seemed to have now taken a backward step with this ver. (I wonder if I can revert to ver 4.22)

Yes I know what you mean, the whole unit has become more sluggish since 5.15 and the update brought little new to the box. However apart from the odd duplicate recording mine hasnt had any issues with deleting (although no doubt thats the next little suprise it will through at me) :mad:
 

dennisdodo

Standard Member
Bother and tarnation

I wish i had found this thread before purchasing the HDT8520.

Am suffering mightily from all the bugs written about above and there are now two holes in the wall which fit the remote and base unit nicely.... hope i can get my money back

Guess its a trip back to the shoppe to purchase the humax.
 

brookheather

Distinguished Member
I noticed last week that Amazon have finally stopped selling it as well.
 

dennisdodo

Standard Member
last night I recorded a half hour program. when i came to replay it later in the evening, the last four minutes twenty seconds played first, followed by the first past/remainder of the program.

I made sure that I was at the start of the recording

Anybody else have this product enhancement?:confused:
 

technogran

Active Member
last night I recorded a half hour program. when i came to replay it later in the evening, the last four minutes twenty seconds played first, followed by the first past/remainder of the program.

I made sure that I was at the start of the recording

Anybody else have this product enhancement?:confused:

It's called 'Auto Review!' :laugh: P.S I am only joking Dennis! LOL
 
Last edited:

dennisdodo

Standard Member
Interesting, but why auto review the last four minutes of a program? if i wanted to spoil the end of a program i would ask a friend, lol

And I have not had the same thing occur on any other recording
 

E Shaw

Novice Member
Ahhh the joys of owning a 8520, it seems to exhibit some very strange behaviour at times :suicide:

My best one is still a triple recording :rotfl:

BBC1, BBC1 HD and BBC3 all one night
 

E Shaw

Novice Member
My 8520 froze up twice on Saturday.
Luckily noticed before I went out so I could reset it.

This seems to happen more often since the last update (5.15 ), the whole unit is more sluggish as well :mad:

Im serioulsy thinking of getting rid of mine after Christmas and getting the Humax
 

willp2003

Active Member
new update out on the site - but the download contains ver 5.15 still? Should be version 6.20 apparently. Will keep an eye on this tonight :)

edit: seems to be v6.20 now

edit2:

ok as far as i can see - The EPG now shows channel numbers, and the text is different (or maybe just squashed up a bit)
From the library you can delete your series folders and it tells you how many recordings are in each one.
e.g Peep Show - the red button says delete 4.
Also if you go into a series folder the is an odd bubble icon with an N in it - presumably to say Not viewed?

The above features/functions only work on recently recorded shows
 
Last edited:

mike.cloaked

Active Member
new update out on the site - but the download contains ver 5.15 still? Should be version 6.20 apparently. Will keep an eye on this tonight :)

edit: seems to be v6.20 now

edit2:

ok as far as i can see - The EPG now shows channel numbers, and the text is different (or maybe just squashed up a bit)
From the library you can delete your series folders and it tells you how many recordings are in each one.

Excellent :)- and thanks for the heads up - I have downloaded the file and will update the box later - and then have fun seeing how much better it is than 5.15! :laugh:
 

Damian1978

Well-known Member
Seems interesting so far. Now have a USB reading option and the box tells you when you are watching an SD version if an HD version is being broadcast.

No 5.1 from what I can tell. Put in HDMI Audio Auto mode and its stuttering like mad :-(
 

Damian1978

Well-known Member
Arrrgh!!! Put in PCM and its stuttering badly on live HD broadcasts
 

mike.cloaked

Active Member
It would be nice to see a changelog for this new version so we know what is different in 6.20 compared to 5.15 - if anyone has seen this please could you post the text to the list?:smashin:
 

Damian1978

Well-known Member
Mines currently unplugged. As soon as any changes are made to audio it breaks up via HDMI!
 

PhilipL

Member
Hi

After all this time and several firmware updates is there anything that can be marked as fixed on the bug list?

Let me know here and I'll update it, it would be nice to see this box finally become stable and reliable.

Regards

Phil
 

willp2003

Active Member
Hi

After all this time and several firmware updates is there anything that can be marked as fixed on the bug list?

Let me know here and I'll update it, it would be nice to see this box finally become stable and reliable.

Regards

Phil

I'd say bugs 8 and 15 are fixed. I'll have to try and test some of the others. I also have been lucky and not had many issues with mine
 

mike.cloaked

Active Member
A few bugs that we have noticed in recent months I will be looking to see if fixed will be the issue of the box locking up at apparently random times and then needing to pull the power plug and restarting the box. Also occasionally for no apparent reason recordings stop short or get recorded but then the list of recordings shows an exclamation mark in a triangle and the recording is unplayable - with the only thing you can do is to delete it.

Anyway will have to test the new firmware over the weekend and will report back with issues fixed, those unfixed and any newly introduced problems! I would still like to see a changelog though.
 

Phildick

Active Member
Looks like they have f***** it up. I have slight stuttering on HD audio now. Both on analog and digital outs

Double checked this morning and can confirm that there is slight stuttering or break-up on all outputs. I have tried HDMI, SP/DIF and analog they all have the same problem.

I have reported this to Philips
 

Damian1978

Well-known Member
Thanks for confirming that.

Was driving me nuts :-(
 
Status
Not open for further replies.

The latest video from AVForums

AVForums Movies Podcast: Which is the best decade for horror movies?
Subscribe to our YouTube channel

Latest News

Hisense TVs get Disney+ on VIDAA smart OS
  • By Andy Bassett
  • Published
Astell&Kern launches entry level SR25 MKII portable music player
  • By Andy Bassett
  • Published
LG rumoured to release 97-inch OLED TV in 2022
  • By Andy Bassett
  • Published
What's new on Blu-ray (UK) for Halloween 2021
  • By Mark Costello
  • Published
AVForums Movies Podcast: 20th October 2021
  • By Phil Hinton
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom