Philips OLED806 sound is buggy combined with Sonos ARC

Pwainx

Active Member
Well I've done some testing for the last week and came to the conclusion that the sound of the Philips OLED806 is very buggy. Let me describe mine setup...

The Philips TV is connected to a Sonos ARC. For most of mine streaming services I use an Apple TV. I prefer this user interface and the smoothness instead of the built in Android apps. I've noticed that the standard setting for eARC on this television is off. But to get Dolby Atmos on the Apple TV this has to be switched to AUTO. Also the sound output is set to 'Multichannel (bypass)'. I have to do this because otherwise I have some lip-sync problems with mine Cable decoder (Telenet).

So far so good. Dolby Atmos is working on the Sonos Arc with the Apple TV, Xbox,... and there are no lip sync problems at all.

However after a while you just can loose the sound on the Sonos Arc. This happens frequently when switching sources. Whatever you do nothing will works. The only thing to get the sound back working is to disable the eARC function or switch to Multichannel. Reenable those will not give you back Dolby Atmos immediately.

Then there is another issue. On the Apple TV everything is working perfectly with Dolby Atmos (Disney, Apple TV+). Except Netflix...This will only produce a ticking sound. Very weird. You can see a video here (don't forget to enable the sound 😉):




I don't know exactly what is causing the problem but I think the communication between the Sonos Arc and the Philips OLED806 is not faultless with eARC enabled.
 
Last edited:

chuck93

Member
I am using a similar setup (Samsung Soundbar instead of Sonos) with the same settings enabled as you, but for me sound is working without any problems.
 

Pwainx

Active Member
It's really strange...So your also having Dolby Atmos?

I have the feeling that the communication between some devices may lead to the loss of the audio signal. I don't know exactly which device this is causing. Maybe it's the Sonos or maybe it's the Apple TV.

I've noticed that disabling the eARC function on the Philips TV will solve all the problems. But then off course you will miss the Atmos experience.
 

Priyantha

Active Member
It's really strange...So your also having Dolby Atmos?

I have the feeling that the communication between some devices may lead to the loss of the audio signal. I don't know exactly which device this is causing. Maybe it's the Sonos or maybe it's the Apple TV.

I've noticed that disabling the eARC function on the Philips TV will solve all the problems. But then off course you will miss the Atmos experience.
You shouldn't loose the Atmos experience with just using ARC by the way when you are using one of the streaming services.
Because these are not using TrueHD + Atmos but just Dolby Digital Plus + Atmos, which should be working with just ARC.
 

Pwainx

Active Member
You shouldn't loose the Atmos experience with just using ARC by the way when you are using one of the streaming services.
Because these are not using TrueHD + Atmos but just Dolby Digital Plus + Atmos, which should be working with just ARC.

For the Apple TV you really need eARC to get Dolby Atmos.


Apple TV 4K uses a high bandwidth form of Dolby Atmos that doesn’t work over ARC connections.
 

chuck93

Member
It's really strange...So your also having Dolby Atmos?
Yes, I am also using Dolby Atmos. More concretely, this is my setup:
-Samsung Soundbar is connected to eARC
-Plex App on 806 is used to play Atmos from Dolby Digital
-Nvidia Shield is connected to HDM1, Plex App on the Shield is used to play TrueHD Atmos
Both works fine for me.
 

Pwainx

Active Member
I've contacted Sonos in the hope they will find something in this configuration. Fingers crossed.
 

Priyantha

Active Member
For the Apple TV you really need eARC to get Dolby Atmos.


Apple TV 4K uses a high bandwidth form of Dolby Atmos that doesn’t work over ARC connections.
Ah yes I see it now, Apple is using 'of course ;)' a other implementation as every other is using they are using MAT 2.0, just like a LPCM stream. Instead of just using it in the Dolby Digital Plus fasion which is also what the content providers are providing on all streaming platforms.

Hopefully you'll get a fix.
 

megagold5

Member
I have had this problem a couple of times with by 2021 9506 Philips TV connected to a JBL Bar 5.0. It only happened when set to bypass and not all the time, so I set it back to multichannel without bypass and it has been fine since - I have not used Apple TV at all and cant remember specifically what I was using at the time, but I suspect it was Youtube.

It still passes through Atmos to the soundbar using PCM multichannel according to the SB display though.
 

Pwainx

Active Member
I have had this problem a couple of times with by 2021 9506 Philips TV connected to a JBL Bar 5.0. It only happened when set to bypass and not all the time, so I set it back to multichannel without bypass and it has been fine since - I have not used Apple TV at all and cant remember specifically what I was using at the time, but I suspect it was Youtube.

It still passes through Atmos to the soundbar using PCM multichannel according to the SB display though.
The problem is whenever I do not use the bypass function I have some lip-sync issues that I can solve. Because the image is running before the audio.
 

leon758

Standard Member
Hi, I too have this problem. I have Philips 856 with Sonos ARC.

At first, I did not realise eARC was defaulted to OFF in settings. For the first 2 weeks, I've been enjoying my TV and getting Dolby ATMOS with Netflix on modern titles (not with Prime). However, I assumed that while I have been getting ATMOS (as my SONS app tells me) it might be compressed as eARC was not switched on.

Now that I have eARC switched on, after about 5 mins I hear a super loud 'pop' (it sounds like the speaker blew) and only the surround sound works. When I switch the tv on and off again the soundbar works again, only to 'pop' and switch off again 5 minutes later. I've since turned off eARC which is super frustrating as I'm not getting true Atmos. :(
 

Pwainx

Active Member
Hi, I too have this problem. I have Philips 856 with Sonos ARC.
This is really interesting. The Philips 806 and 856 are technical the same...so there must be an issue.

Still not know if the problem is with the Sonos Arc or with the Philips TV. Do you also use an Apple TV or just the built in Android applications?
 

delBoy75

Novice Member
as mention on other forum Pwainx - having same issue and i am running samsung q70 soundbar with eARC...it's the TV and not the soundbars...never has this issue on the 805 or my LG TV! Does philips have a support - may be worth just showing them this thread regarding the sound cutting out randomly...
 

Conroy

Standard Member
My set up is 856 and Sonos Arc - I'm not having any issues so far with Atmos over eArc using the Android apps
 

Pwainx

Active Member
My set up is 856 and Sonos Arc - I'm not having any issues so far with Atmos over eArc using the Android apps

If I use the Android apps on the television itself I also don't have any issues.

Probably the reason for this is that those apps don't require eARC at all. You can disable eARC and still get with the built in apps Dolby Atmos. Those apps are using a compressed version of Dolby Atmos.

But the Apple TV uses a high bandwidth form of Dolby Atmos that doesn’t work over ARC connections. If you disable eARC then Dolby Atmos will not work with the Apple TV. The Apple TV really uses the benefits of eARC where the built in apps don't.
 

megagold5

Member
The problem is whenever I do not use the bypass function I have some lip-sync issues that I can solve. Because the image is running before the audio.
Hmm, yeah, havnt had any sync issues at all with my setup so far actually. If its a consistent sync issue maybe you can offset it on the soundbar itself? I havnt seen any sync setting on the TV itself, although I havnt really looked either.
 

Pwainx

Active Member
Hmm, yeah, havnt had any sync issues at all with my setup so far actually. If its a consistent sync issue maybe you can offset it on the soundbar itself? I havnt seen any sync setting on the TV itself, although I havnt really looked either.
If you set a delay on the sound (which is the only option you always have) you'll make the situation worse. This was a solution if the audio is before the video. But the video is running before the audio. 😒
 

megagold5

Member
If you set a delay on the sound (which is the only option you always have) you'll make the situation worse. This was a solution if the audio is before the video. But the video is running before the audio. 😒
Ah ok. I only asked as my previous LG was able to set the audio to offset in both directions.
 

Pwainx

Active Member
as mention on other forum Pwainx - having same issue and i am running samsung q70 soundbar with eARC...it's the TV and not the soundbars...never has this issue on the 805 or my LG TV! Does philips have a support - may be worth just showing them this thread regarding the sound cutting out randomly...
As Sonos and Netflix don't see any issues...I have contacted Philips and created a case for this eARC problem. Hopefully they will invest the problem seriously.

Maybe others can also create a case for this problem. If more people are reporting their issue with eARC then maybe they really want to investigate this. You can create an account on https://tv-sound-monitors.philips.com/ and then create a ticket for this problem.
 

Conroy

Standard Member
If I use the Android apps on the television itself I also don't have any issues.

Probably the reason for this is that those apps don't require eARC at all. You can disable eARC and still get with the built in apps Dolby Atmos. Those apps are using a compressed version of Dolby Atmos.

But the Apple TV uses a high bandwidth form of Dolby Atmos that doesn’t work over ARC connections. If you disable eARC then Dolby Atmos will not work with the Apple TV. The Apple TV really uses the benefits of eARC where the built in apps don't.
I may have spoken too soon. I do have an issue if I cast a video to the TV from a web player
 

Pwainx

Active Member
Well I've installed the latest firmware today and I've got some good news! I finally can use the Apple TV with Dolby Atmos without any issues. No weird ticking sounds anymore with Netflix and other apps on the Apple TV.

I still need to use 'Multichannel Bypass' because the regular Multichannel output will still cause some lip-sync issues with mine TV cable decoder. But that isn't a big issue because the bypass output seems to work better now.

I still have encountered that there is no audio when switching from several sources. But mostly I can correct this by switching again to the same HDMI source that is playing at that moment.

It still too early to say that this new update fixes all the audio problems but it seems that Philips has definitely worked on this.
 

Pwainx

Active Member
I did some more testing and sadly need to say that not everything is solved. For most off the time the audio (Dolby Atmos with eARC) will work. But sometimes you'll have no audio at all. It's not always easy to get the audio back to work. Sometimes you need to switch eARC off and then to auto and restart the video device.

Then there is something very weird. You hear some audio that is meant for the front central speaker coming out of the rear left speaker.

So this new update will solve many frustrations but sadly it's not a perfect solution. There are still some issues when using the eARC port.
 

Pwainx

Active Member
Well I was wrong. This new update TPM211EA_R.001.001.212.206 will solve some issues with Dolby Atmos when using an Apple TV. But then...it introduce some new ones. 😤

When playing a Dolby Digital 5.1 signal through the Apple TV you will notice that the audio signal for "front right", "front left" and "rear left" are played by the "front center" speaker. The audio signal for this center speaker is then replayed by the rear left speaker.

You can check this by installing the Apple TV app 'Surround Speaker Check'. It's free. Mine settings are 'Multichannel bypass' and eARC in AUTO.

When using a Dolby Atmos signal it seems to work fine.

Then there are some other issues when starting Dolby Vision videos. Someone else already created a topic about this: 55OLED806 -Dolby Vision software bug

It really seems that the software for the 806/856 is very buggy. There's still a lot of work to do. At the moment it is frustrating with using this TV. It's not a good start for Philips.
 

Madchemic40

Active Member
Well I've done some testing for the last week and came to the conclusion that the sound of the Philips OLED806 is very buggy. Let me describe mine setup...

The Philips TV is connected to a Sonos ARC. For most of mine streaming services I use an Apple TV. I prefer this user interface and the smoothness instead of the built in Android apps. I've noticed that the standard setting for eARC on this television is off. But to get Dolby Atmos on the Apple TV this has to be switched to AUTO. Also the sound output is set to 'Multichannel (bypass)'. I have to do this because otherwise I have some lip-sync problems with mine Cable decoder (Telenet).

So far so good. Dolby Atmos is working on the Sonos Arc with the Apple TV, Xbox,... and there are no lip sync problems at all.

However after a while you just can loose the sound on the Sonos Arc. This happens frequently when switching sources. Whatever you do nothing will works. The only thing to get the sound back working is to disable the eARC function or switch to Multichannel. Reenable those will not give you back Dolby Atmos immediately.

Then there is another issue. On the Apple TV everything is working perfectly with Dolby Atmos (Disney, Apple TV+). Except Netflix...This will only produce a ticking sound. Very weird. You can see a video here (don't forget to enable the sound 😉):




I don't know exactly what is causing the problem but I think the communication between the Sonos Arc and the Philips OLED806 is not faultless with eARC enabled.
Here is what I did to minimise audio lag.
Set Audio out to Multichannel, roll down to audio out delay and set it to off.
You can only set audio delay to off if Multichannel option is selected.
Disable ALL unnecessary picture processing and AI options, use Filmmaker mode in SDR, HDR and Dolby Vision Dark/Bright.
Then go through ALL 3 options on your Apple TV as video outputs ( SDR, HDR, Vision) and do the wireless audio calibration. You will have to switch audio out to TV speakers when doing this calibration.
After you did all that switch back to SDR option on ATV and enable match dynamic range and frame rate.
Hope it helps.
 
Last edited by a moderator:

The latest video from AVForums

AVForums Movies Podcast: Which is the best decade for horror movies?
Subscribe to our YouTube channel

Latest News

What's new on Blu-ray (UK) for Halloween 2021
  • By Mark Costello
  • Published
AVForums Movies Podcast: 20th October 2021
  • By Phil Hinton
  • Published
PSB announces M4U 8 MKII wireless headphone
  • By Andy Bassett
  • Published
Melco introduces N50-S38 music library
  • By Andy Bassett
  • Published
Sony expands 360 Reality Audio to Amazon Music Unlimited
  • By Andy Bassett
  • Published
Support AVForums with Patreon

Top Bottom