Philips Ambilight PUS7906 Juddering

NUFC1977

Novice Member
Just purchased my first Philips TV (50PUS7906), loving the Ambilight and TV overall however, I’m having issues on a number of apps with juddering/stuttering (not sure which tbh?) on a few installed apps.

Picture is fine on Sky Q mini (playing in 1080p) but everything I’ve tried on Disney+ (Moon Knight, Dr Strange, Star Wars)/Prime (Picard, The Boys No Time To Die), and BT Sport seems to judder although Netflix doesn’t seem as bad (The Witcher ((in Dolby Vision/Atmos)), Better Call Saul seemed perfect with only Wolf of Wallstreet having the issue so far)?

There doesn’t seem to be a motion/HDR section in the settings menu which is the suggested fix from most of the places I’ve looked online along with changing to either sport or game mode which hasn’t resolved it, has anyone else had similar issues and sorted it?

I’m not hugely tech savvy but can usually get these things figured out using online guidance but can’t find anything that works so far!?

Any help would be appreciated, thanks in advance!
 

Nj125

Novice Member
Just purchased my first Philips TV (50PUS7906), loving the Ambilight and TV overall however, I’m having issues on a number of apps with juddering/stuttering (not sure which tbh?) on a few installed apps.

Picture is fine on Sky Q mini (playing in 1080p) but everything I’ve tried on Disney+ (Moon Knight, Dr Strange, Star Wars)/Prime (Picard, The Boys No Time To Die), and BT Sport seems to judder although Netflix doesn’t seem as bad (The Witcher ((in Dolby Vision/Atmos)), Better Call Saul seemed perfect with only Wolf of Wallstreet having the issue so far)?

There doesn’t seem to be a motion/HDR section in the settings menu which is the suggested fix from most of the places I’ve looked online along with changing to either sport or game mode which hasn’t resolved it, has anyone else had similar issues and sorted it?

I’m not hugely tech savvy but can usually get these things figured out using online guidance but can’t find anything that works so far!?

Any help would be appreciated, thanks in advance!

I only found this thread due to my TV having the same issue for a number of months now.

I have no solution for you unfortunately. Unplugging and waiting a minute before plugging back in stops it temporarily but it becomes a real pain to do that in the middle of something you are watching.

Philips technical support will ask you to update the TV to latest software, reduce the number of apps you have on the Android TV home screen etc. They even suggested a recovery which worked for a few days but didn't stop it happening.

I updated software to the most recent version on Thursday evening but the issue started happening again on Saturday afternoon.

I've reported this back to Philips so will see what they say.
 

NUFC1977

Novice Member
Thanks for your reply, I’ve got the latest software installed so don’t think it’s down to that.

I’m guessing it’s a video format thing as like I said the majority of Netflix seems perfect (have since found issues on Friends ((HD format)) and a couple of cartoons) but I’ve yet to find anything on Disney+ or Prime that plays without the judder and having had a play with a few settIngs they made no difference and unlike my LG C1 and similar priced Hisense (to the Philips, not sure on the model) the Philips doesn’t have a menu option to change HDR/motion settings which from googling usually resolves the issues.

As mentioned I like the Ambilight feature and the TV in general but now weighing up whether to return it and maybe swap it for an LG or something if it’s not going to play UHD as it should?

Hopefully someone has a fix or can get a solution from Philips (doesn’t sound likely) 🤞
 

Nj125

Novice Member
I don't think it's even down to the format.

I've tried several different YouTube videos (30 fps vs 60 fps), swapped to Netflix and the issue has stayed the same. I've seen the same happening on Disney+ and Prime. My partner uses HayU and sees the same thing.

I recorded it.

Make sure you watch it in 60 fps. Does it look like the same issue?
 

NUFC1977

Novice Member
I don't think it's even down to the format.

I've tried several different YouTube videos (30 fps vs 60 fps), swapped to Netflix and the issue has stayed the same. I've seen the same happening on Disney+ and Prime. My partner uses HayU and sees the same thing.

I recorded it.

Make sure you watch it in 60 fps. Does it look like the same issue?

Yes that’s exactly what mine was doing, I say ‘was’ as having contacted Philips they advised me to do a ‘One Button Recovery’ which for the time being has resolved the issue (May be temporary judging off your earlier reply?).

It’s a strange one as like I mentioned, majority of Netflix worked fine but nothing worked on the apps I mainly use! Will see how ‘the fix’ goes and get back onto Philips if/when it returns, think the next step is to send them a video of the issue to investigate further. The only other thing I could think of it being is the WiFi signal (although the tv is saying signal is good) so will maybe try connecting via LAN should it reoccur? 🤞
 

NUFC1977

Novice Member
As per your previous reply all apps worked fine for a couple of days with the issue now returning (same tv shows juddering/not juddering as before). I tried connecting via Ethernet just in case it was a WiFi issue but that didn’t make a difference.

I’ve uploaded a video to Philips support and awaiting a reply. Will update if I hear anything further 😳
 

waynepyrah

Standard Member
These TVs are so buggy, just use Chromecast and the apps on your phone seems to work, shouldn't have to do that but you know 🤣
 

The latest video from AVForums

Paramount + UK launch: Halo, Star Trek and Beavis, and all the latest 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom